Major issues with the MyCloud PC app

When I first installed the WDMC I did not install or use any software other than the browser interface that is built into the hardware.  It was easy to set up and works OK.  I can transfer files via Windows.  But, such transfer is slow, good enough for individual file sharing and incremental backups, but for an initial transfer of gigabytes of small files I am looking for alternatives.

Rumor had it that copying from a directly attached USB drive, using the MyCloud app, may be faster.  My actual experience shows that this app is useless for the purpose.  One fatal flaw is that the files’ date stamps are lost.  Also the UI is terrible and erratic.  More details below.

I have tried using the MyCloud app for Windows.  The user interface is simple - but TOO simple, and buggy:

* looks a bit like Windows File Explorer, but folders only show up in the left
side navigation panel.  Only files, not folders, are listed on the right.

* Dragging something to COPY it (between USB drive and internal drive, for example), the cursor gets a “+” added to it, which in Windows means it will copy rather than move, but what this app actually did was move the file or folder.  Not what I wanted.

* Tried to move or copy FOLDERS by dragging them within the left panel. The results were erratic: sometimes it affected the parent folder along with the child folder that I dragged.  And sometimes it moved a different folder from the one I dragged.  This happened several times, so it’s not just that my fingers stumbled once.  The net result after several tries was a total mess that I could only fix via Windows, outside the app.

* Copying of a large number of small files from PC to WDMC using this app was VERY slow.  About one second per file, no matter how small.

* Some large files failed to copy for no apparent reason.  They were listed  in an error report panel, but only the file names, not their locations (although their pathname appears if you hover the mouse over an entry in the list).  These files copied perfectly well via Windows.

* The files copied via the app lost their Windows date stamp: on the WDMC the date stamp was set to the copy date (both the “created” and “modified” dates, as it appears in Windows).  This is a loss of important metadata.  When copying files via Windows the “date modified” is preserved and the “date created” is set to same as “date modified”.

If a file on the WDMC is modified in place then both dates get updated.  In the MyCloud app only the “date modified” appears.  Presumably the file system on the WDMC only keeps one date stamp for a file?  Even so, the app could have been designed to preserve one of the Windows dates when copying files from Windows.

* Even when transfering from USB drive attached to the WDMC, the date stamps are lost.  Thus it’s useless to me.

* To copy or move a folder, since it does not show up in the right pane, I had to drag it within the left pane (folder tree).  But if I needed to drag it to a folder that is past the visible part of the list, there was no way to get there.  The list did not scroll when the mouse cursor reached its edge, as happens in Windows.  And while files in the right pane have a right-click pop-up menu which includes “copy” (but not “select all”), folders in the left pane do not.  So the operation was impossible.

In summary, this app is a sad joke as a file manager.  WD needs to rewrite it from scratch.  Fortunately one can use the Windows File Explorer to do the needed file management.  Unfortunately copying from a USB drive directly attached to the WDMC, to the WDMC internal drive (or vice versa), then involves a round trip through the network and the PC, resulting in slow transfers.  Also, presumably one has to use this app when accessing the MyCloud remotely, from a PC that is not on the same local network?  If so, it might be useful for individual file access, but totally useless for folder operations.

mbraner wrote:

[…]  Also, presumably one has to use this app when accessing the MyCloud remotely, from a PC that is not on the same local network?  If so, it might be useful for individual file access, but totally useless for folder operations.


Remotely, you can use th desktop app or the website. The website requires the Java plugin, and the corresponding Java app can be an issue for certain platforms (doesn’t work very well on Mac/Safari) or environments. But when it works, it allows you to mapp a remote share to a drive on your computer using the WebDav protocol. This protocol is not perfect when it comes to MS Office files (security) and media streaming, but the user interface is the native file manager of your computer.

OK, happy to hear there are alternatives to the MyCloud desktop app even for remote access.  I have not tried remote access yet because I don’t really understand how it works, and am worried about security as it clearly gives some sort of access to my files from the world at large.  Are there options besides those two (desktop app and wd2go website)?  Direct access to WebDav somehow?  How about FTP access directly to the WDMC?

Talking about FTP, would that be a faster way to transfer files from the PC to the WDMC?  But what would happen to the date stamps?

To be honest, I never looked at the time stamp issue, so I cannot comment.

You can set up the NAS for FTP access. A toggle switch in the admin UI is all what you need on the local network. Remote FTP access can be enabled by forwarding an external port of your router to the port 21 of your NAS, and using potentially a dynamic DNS service to that it is easy to track down your WAN IP as it might change. One aspect of remote FTP is security, starting with the lack of encryption of the credentials to login. Most FTP clients support security protocols to enhance FTP (like SFTP, and leveraging SSH type key exchanges), but I have not tried them. Documentation about them is widely available, so you can experiment.

Going through the WD desktop app and/or is secure (now that the SSL thing has been patched by WD). When you access your NAS remotely you use 2 sets of credentials. The first one is to access the service which tracks where you NAS is on the Internet, and provides the secure remote access. The second set is the NAS user credentials and the share rights you have set up. The only common point between the 2 sets is that the email address you use to acess the service is the email address you have set up a NAS user with when you enabled that user with remote access on the NAS UI. The password can be difference for both set of credentials.

Good info on both the FTP options and the wd2go method, thanks.

How about FTP for local transfer from PC to WDMC?  That’s what I am trying to speed up.

One more issue with the app that I forgot to mention: after plugging the USB drive into the WDMC, I could not find any way to safely disconnect it.  Other than perhaps going through the WDMC shutdown operation, buried deep within the “dashboard”.  Looking for a solution in the manual, I found that there is an “eject” option in the separate WD “quick” app.  I could not install that app on my system because it requires .net 4 which I don’t have on my old WinXP PC.   (Yes I could install that too, but I try to avoid “upgrades” that aren’t really needed.)  In any case, an “eject” option for USB drives really should be built into the MyCloud app, and also into the Dashboard.

mbraner wrote:

[…]  Other than perhaps going through the WDMC shutdown operation, buried deep within the “dashboard”.  […]


When you look at the NAS UI, there is a USB logo on the top right, if you click on it, you will see an eject button in the bottom right of the pop up window that shows the available capacity.