Major issue with 4tb WDMYCLOUD

I’m having major issues with my WD MyACloud and I’m hoping someone can help. A few days ago, my drive was running very slow, almost to the point of being unresponsive. I rebooted it, waited a while, then started copying files off of it via FTP. I copied off about 2 TB and everything went smoothly. I tried accessing the drive via Windows Explorer and everything worked pretty much as normal. The next day, the drive was once again very slow to respond. Once again I rebooted it. This time I had a yellow flashing LED for several hours. I could ping the drive and look at the dashboard, but the dashboard took about 20 minutes to open. It showed no free space on the drive and had a status of idle.

Since then things have really gone downhill. When I reboot the drive now, the LED stays solid yellow for several hours. After that, the LED turns off. (for a while it turned red) I can ping the iP. I can get the login for the dashboard. I’ve logged in, but if I change any settings, it says “UPDATING…” and stays there for a few minutes before saying that I should check for network errors. I connect via SSH and it takes about 5 minutes to give me the login prompt, but then disconnects before I can login. The drive is visible on my network, but I can’t connect to it.

I’m no longer receiving any messages from it, but previously I received a few e-mails from the drive that said:
Following events are generated on your WDMyCloud .
Event title:Data volume failed to mount
Event description:The data volume on the drive is not accessible. Please contact customer service.
Event code:0004
Event time:04-24-2019 11:18:11 AM
Firmware version: 04.05.00-320

Does anybody have any ideas on how to save my drive? I’ve got close to 4TB of data on it and less than half of it is backed up.


After rebooting numerous times, my drive is now partially working. I can access the dashboard, despite it being extremely slow. I can access the shared folders, but it is painfully slow to do anything. The LED is off. It stays yellow for about 15-20 minutes after rebooting, then it just turns off. Lastly, when trying to change settings in the dashboard, some options are greyed out and some generate errors. Can anyone help?


When you are able to access the My Cloud Dashboard how much free space is left on the device?
If able to access the Dashboard click on Diagnosis to see if there are problems with the drive.
Can you access the My Cloud using SSH (assuming you’ve enabled SSH in the Dashboard)? And if so is it still sluggish using SSH?

I have about 2TB of free space according to the dashboard. (That actually seems high to me.)
Unfortunately, the diagniostics options are both greyed out and I cannot click on them. I do have ssh enabled. It takes about 20-30 seconds for it to respond to anything that I type, including logging in. Is there any way to run the diagnostics from the ssh session?


Another update. After leaving my browser sitting on the Settings–> Utilities Screen for a while, both diagnostic options became available. It passed the 1st self test but when running the full test it kicks back an error message saying " * Smart test bad request. (400157)" Shortly after that I get another popup saying
" *Failed diagnostic test.
*Navigate to [Support] and create a system report to troubleshoot or obtain automated customer support from WD."

I click on the link, then take the option “Create and Save System Report”. The browser says that it’s waiting for the ip address of the drive but nothing else. Clicking on the “Request Support” button basiclly does the same thing. (unless I’m not waiting long enough, about 15 minutes so far).

Any ideas?

Usually when a drive fails the SMART test or indicates SMART errors it means there may be problems with the drive and that drive may be going bad.

Creating a system report can sometimes take some time. Although 15 minutes may seem too long. If your My Cloud is already sluggish then that report generation could take a significant amount of time.

If the My Cloud is no longer under warranty one could remove the My Cloud hard drive from it’s enclosure. Connect it, using a spare SATA port on the computer or using a USB to SATA adapter, to a computer running Linux or running a Linux driver and copy the user data off the potentially failing My Cloud hard drive.

I’ll have to look into that. My main issue is not having the space to restore all of the data. I’ve got 3tb of disk in my system, but over 2 TB of it is used. The stuff on my WDMYCloud is additional data that I would have to find room for. That will be a real challenge.