Main Menu Freeze - Help Please

After several months of excellent viewing my WD TV Live Media Player has suddenly frozen at the main menu screen with no hint of any issues prior to the failure.:cry:

I have tried the reset button. I have tried disconnecting all leads and power sources. I have checked the batteries both existing and new but none of these attempts have been successful.

The unit runs through its loading cycle but when it gets to the main menu it freezes on the video option. I cannot scroll up or down the menu. Pressing enter does nothing. Pressing home or the power button does nothing. The only way to turn the unit off is at the plug.

Because I cannot scroll the unit in any direction I am unable to let you know which firmware version is loaded so I do not know if an update is required.

Can anyone offer any solutions?

If you or a friend has an iPhone, iPod Touch, iPad, or Android device, try loading the new WD Remote software and see if it detects and can control the WD.

Or, use a plain vanilla USB keyboard.

If either of these work, then it’s one of these things:

   1-  Your remote control is dead.  WD will replace it.

   2-  Your I/R receiver in the box has died.

   3-  Your WD is receiving stray infrared from another source (a remote with a jammed button or something…)

Thanks for the feedback

I will try a couple of your suggestions and let you know if I have any success.


I thought that the new WD Remote software was only for the Hub and the new Streaming Media Player. I am pretty sure that it does not work for the Live/Live Plus (going by WD’s own description of it).

D’oh!  Scandy is right…  I’ve gotten lax in looking at the forum headings… 

So strike that option unless you have the 2011 model of the WDTV Live.

Thank you to the individuals who responded to my problem but just to let you know that after leaving the unit alone for a couple of days it started working again.:smiley: