macOS Sierra upgrade/downgrade

I just tried to downgrade the macOS Sierra on my MacBook and was going to restore my laptop from my Mycloud hard drive. I don’t see it listed when restoring using command and “R” on reboot. I tried to copy the files from the Time Machine folder onto a WD Passport but when I try to move the files into the Time Machine folder it will not allow the files to be moved.

I don’t believe I can restore my MacBook to the previous version from yesterday before I did the iOS upgrade.
Any suggestions?

Hi, I am not a Mac user, hopefully another user will be able to provide some assistance.

Clean install from USB stick and after boot into the new system restore from Timemachine/WD.

  1. hold command-R on boot up
  2. Before you start the restore make sure you are on ethernet rather than wifi by selecting Utilities, Network Utility and select your ethernet network interface for information to check that it is accessible. Then click on the upper right corner on the WIFI symbol and turn off WiFi. Then exit network Utility
  3. select “Restore from time Machine Backup”, then select continue
  4. most likely searching for Time Machine backups won’t find it but if it does it might only try to connect to your Cloud Device and not your share such as “WDMyCloud” without a share name. It will prompt you for a password and after you enter it, it does nothing. So… select “Other Server”
  5. Enter your Cloud Name followed by the share name, which is usually WDMyCloud and TimeMachineBackup in the format smb://WDMyCloud/TimeMachineBackup
  6. it will then prompt you for your name and Password.
  7. now it should come back with your Time Machine backup as one of the selection under “Select a Backup Source”
  8. select your time machine backup and click on continue.
  9. select the backup date & time that you want restore… click continue
  10. select destination disk and click restore
  11. are you sure…?