macOS Monterey

By the way, thinking about your picture attached, this is not a “crash message”, it’s simply the request to allow sharing crashes information. You can keep going the installation wizard.

I’ve held off on updating to Monterey (I have a 19" 2019 Intel MacBook). Is your laptop similar? Do you think it’s safe to go ahead and update now?

Once again WD falling behind with mac OS updates, three years in a row!! I will give you that, very consistent dropping the ball.

I just upgraded to Monterey 12.01. At first, even though the WD Discovery app started up and I could see my devices, I wasn’t able to access them.

Simple fix is to uninstall and reinstall the WD Discovery app for Mac and now everything is working fine.

I can install WD Discovery I just keep getting an message when I sing in to go to Security in Preferences to allow extensions. There is no such choice there and then when I go the System Preferences and click on extensions all the WD Extensions are enabled??

I have uninstalled and reinstalled multiple times and have restarted the drive and the computer multiple times. MacBook Air running M1 Processor

THanks!

2 Likes

same 4 me

1 Like

I have the same problem. I’m not able to sign in. this message shows up. “Your operating system extention ask for approval. Go to preference > Security & Privacy > general tab. And click the allow botton.” But this allow button isnt ther

After restarting the mac, several times the problem has been solved

Hi, I just bought a MAC Mini with OS 12.1 (Monterey) and M1 chip. I have a MyCloud Home Duo (16GB). I downloaded WD Discovery for Desktop for my MAC Mini and it installs ok, but when I sign in to it says “Your operating system’s extension needs approval. Go to System Preferences->Security->General and click on Allow button”. I’ve done this before for other apps on my old iMAC Sierra no problems, but the ‘Allow’ button does not appear on my MAC Mini to allow me to allow the extension. I contacted WD and they have just said to reinstall WD Discovery and reboot the Mac and MyCloud Home Duo. I’ve done both of these things and continue to restart MyCloud Home Duo and my Mac every day, but still don’t get the “Allow” extensions button appearing in Mac Preferences–>Security->General tab. Any other thoughts to fix it? WD Discovery desktop app works fine on my MacOS Sierra machine, so seems like a Monterey issue to me

I think you still need to enable reduce security: Install WD Discovery for My Cloud Home for Apple M1 ARM Processor

The WD Discovery installation and operation process on Apple M1 Processors requires enabling Reduced Security within the Apple Startup Security Utility.

1 Like

Thanks Austin. Those instructions were great and solved the problem. I was hoping not to need to reduce security, but if that is the only way to make it work, then I’ve relented. I’m hoping WD may have a fix down the track to allow returning to full security again in the near term?

1 Like