MacOS 13 Ventura Thread

As usual, new MacOS update is out for developer beta, and it breaks mounting the My Cloud Home via the file system. WD Discovery is unable to mount or see the drive.

WD was quite slow fixing this the past couple years, at times not fixing it until after the public release has been pushed. Just using this thread as an update thread so we can know when the issue is fixed.


Hi @bmac39,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

I have. There’s not really troubleshooting to be done, as it’s an issue on your guys’ end.

This isn’t entirely unexpected, as beta software should break things so that they can be fixed before release, but there’s been quite a few major releases of MacOS that you guys have not supported for months after a full public release. I’m hoping this thread helps bring awareness to it, and also would be a public record that WD has known the update does not function on the new software WELL before the public release.


I normally always update to the beta software for work purposes I can help test if there’s any new version of the WD software available

Likewise here. If there’s any beta version of WD Discovery, I’d be glad to test.

Just got off the phone with Support for my ticket that @Keerti_01 requested I open. I was told that they will start work on updating Discovery AFTER the public release of Ventura. I think this is probably why an update was months behind on previous releases.

WD, you have multiple people in here offering to test a beta of Discovery so it is ready to go for a full public release. Hopefully what the support agent told me was NOT true, and you’re actually testing and developing the application for the full release. After all, that’s the entire purpose of a beta.


It’s quite sad that WD is not forward-looking and proactive in preparing for upgrades of operating systems. I guess this tells me all I need to know: they really aren’t interested in being ahead of the game. They prefer to be followers.

1 Like

Following this, I’m in the same boat and would be willing to test Discovery too.

Hi, so annoying it is still not working. It’s the ONLY app that has trouble with the beta which is crazy!

Following this topic too.

The latest beta macOS Ventura 13.0 Beta (22A5342f) the issue persists. After one copy operation to connected share on my WD PR4100 device, the connection is dropped. It is very annoying. Cannot copy multiple files (only compressed archive).
And Time Machine Backup is not working either.
I reported this problem in feedback app from Apple couple weeks ago but still no sign form their side.


Version: 4.4.396 (9/13/2022)

  • Added support to mount drive in macOS Ventura for My Cloud Home and ibi devices
  • Support for enabling memory integrity for Windows 10 and above

Quite impressive. Before even Apple launched. Does not tell, if it still requires to reduce security mode on Apple Silicon



The downloads for the new version of WD Discovery can be found in the following announcement post:

NEW Release (9/13/2022) - WD Discovery 4.4.396 Available

If using the M1 ARM processor, the following steps will still need to be followed for proper installation/functionality:

My Cloud Home: Install WD Discovery for My Cloud Home for Apple M1 ARM Processor

If there are any questions/concerns or assistance needed, please open a case with our support team at:


But what about MyCloud OS 5? There is no newer version than 5.23.114 (published in July).
And with my PR4100 I have the connectivity issues over SMB in macOS 13 Ventura: the connection is dropped after each operation (copy of one file or creating a folder).

1 Like

@Soruk Have you got case opened with Support ? Please use the below link if you haven’t.

Yes, i did it but no response. Case number is 220913-003725

Finally got mine working! So nice to see it mount.