MacBook Pro will not connect to EX4 using Finder

Hi there, I need some help. I’ve searched all over the web and cant find a solution to this, lots of attempts but so far nothing has worked.

I have an “Early 2013” MacBook Pro Retina running OSX El Capitan 10.11.6. I am trying to access my EX4 through the “Finder” on my Mac and it will not connect. I can access it through the WD MyCloud App, but I need to use finder so I can upload some more files.

Is there a fix for this, any ideas? It seems like this is a problem with El Capitan, and WD’s suggestion was to upgrade to El Cap ver 10.11.2, which is several updates ago. I figured by now they would have this figured out, but I can’t find the solution. This is massively frustrating.

Any ideas? Thanks…


Are you able to access the EX4 using the application on that computer or a different system?

Have you tried resetting the drive and testing that again?

Yes. I can access it just fine using the WD My Cloud App, but no through the Finder.

I can also access the server just fine through my old Windows 7 desktop PC. I have reset the EX4, restarted the Mac, and it still will not connect. I have also tried to access it through the finder via wi-fi or ethernet, neither works.

Any ideas?