MacBook cannot find WD My Cloud (but iMac can)


Being a newbie on this forum, i decided try my luck here.

My iMac Mid 2007 with OS X 10.11.6 can find my WD My Cloud flawless and i can sync files with WD Sync.
My MacBook however, End 2008 with OS X 10.11.6 as well, refuses to connect to WD My Cloud.
Both Macs are connected to the same (home-)LAN
Finder’s option Go > Connect to server > afp://wdmycloud.local gives :“Server doesn’t exist”
Same for smb://wdmycloud.local or for afp- or smb-to IP address of the WD NAS.

Tried everything but couldn’t find a solution and any help would be appreciated.

Is the MacBook using the same workgroup name as the iMac and My Cloud? Does it have an IP address in the same range as the iMac and My Cloud? Is there a firewall being run on the MacBook? If so try disabling it as a troubleshooting step. Does the MacBook see other devices on the local network including the iMac?

Thank you Bennor for looking into my question. To the best of my knowledge, Macs don’t use workgroups and i tried the other hints you gave but without result. Both Macs are on the same home-network and i’m getting the impression that a solution must be found around permissions. Will do some more digging … :slight_smile: