Mac OS12.0.1 problem connecting to G-Drive Mobile USB-C

G-Drive Mobile USB-C connection failed after updating MacBook Pro to Mac OS 12.0.1, Monterey. No solution found. Any suggestions?

1 Like

Hi @lpjakob,

Do you get an error message on your Mac, or does it simply not connect?

Have you done these resets on your Mac? -

Does the drive work properly in Safe Mode: Start up your Mac in safe mode - Apple Support?

Cheers,

Jack

Jack: The error received was unable to mount, error 0. I also tried to erase the drive and to reformat. Result is unresponsive, light just blinks, drive is running but nothing happens. I left it running for over 24hrs, still unresponsive. I had to unplug.

I have not performed any Mac resets since there are no other issues. I was using the G-Drive for Time Machine only. I have now switched Time Machine to my NAS and it is working perfectly. As far as I can tell, the G-Drive seems to be unusable.

Same problem except I upgraded my iMAC to Monterey 12.0.1. Now I cannot see my G-DRIVE mobile USB-C drive at all. I used the drive for Time Machine backups. Any ideas please?

By the way, I have an older Seagate external drive which I’ve connected to my Monterey iMac and it was recognised instantly and I’ve copied files to it.

1 Like

I just bought the G-Drive. It doesn’t load up at all with Mac OS Monterey. My work computer has Big Sur and it works just fine. Doesn’t help me much when I want to move my files back and forth. Any idea when they will fix the issue? I could have really used the drive today.

Jennifer

1 Like

I did issue a trouble ticket with G-Technology on 30th of October. Received email today asking for picture of back of drive and purchase receipt. I have provided the requested information. Now waiting for G-Tech response.

Mac World states multiple problems with USB-C devices after upgrading to Monterey. Apple support states only use recommended USB-C devices. I purchased the G-Tech G-Drive Mobile USB-C drive because it was recommended by Apple and sold in Apple stores as well as Apple online store so this response from Apple does not hold true. I will post results once I have a response from G-Tech.

2 Likes

Yeah, I bought mine last week hoping it is the most compatible with MAC. I hope they fix it soon. t’s owned by WD and their drives are horrible with mac.

I’m also having issues with my GDrive EV Raw SSD. It just constantly flashes, won’t allow my macbook to shutdown, won’t eject, and won’t copy files to desktop or delete files to trash. After about 30 minutes the blinking stops and it works as normal but I’m getting tired of waiting so long for it to function. I clicked get info on the drive and for some reason the Monterey update modified it but I don’t know what it did.

1 Like

I have also just upgraded to Mac OS 12.0.1 operating system.

My G Drive has stopped working, I got an error message stating drive was not loadable.

Try a few things to load the drive image but nothing worked.

I use this drive to backup a number of different Macs running various versions of the OS, it very important I don’t lose this data.

Can anyone advise how to fix or do we need a new driver ?

Thanks in advance for you assistance.

1 Like

I have the same problem with my G-Drive and my MacBook Pro. As soon as I have upgraded to Monterey 12.0.1.

I have spent hours on the phone with Apple technicians and I went today to meet their guys at the store for almost an hour. They ended my consultation by telling me to contact G-Technology. That’s what I did… No solution there. The WD Customer Service guy ended our conversation by telling me that either WD will find a solution or Apple will… He couldn’t tell me where, when or by who the solution will be made available. Is somebody really working on the issue.

Bonjour. Je confirme le probleme. J’ai acheté un nouveau macbook pro 14’ en version monterey 12.0.1 et le disque dur en même temps. Le disque n’est pas détecté. Je suis revenu en boutique apple. Le technicien a reformaté le disque dur avec un mac qui était dans une version d’OS anterieur et là miracle cela a fonctionné. Pour Apple il y a un probleme de compatibilité avec Moterey 12.0.1

1 Like

Si je comprends bien, il faudrait donc que je retourne en boutique. Ensuite je leur demande de mettre les données de mon disque externe ailleurs temporairement. Ils doivent ensuite reformatter le disque externe avec Big Sur, puis remettre les données dessus. Si j’ai bien compris, cela aurait des chances de rendre le disque externe à nouveau accessible sous Monterey 12.0.1?

Can I expect that reporting an issue on this forum is likely to illicit a fix?

I’m having similar problems with the 2021 MacBook Pro (running Monterey) and a brand-new G-Drive (USB-C). When I first connected it, it failed to mount (the “mount_hfs” process was stuck indefinitely). I then connected it to my old MacBook (via a USB cable) and it got mounted without any issues. I ran Disk Utility (on the old MacBook running Mojave) and re-initialized it with a single APFS partition (as opposed to HFS+). After that, it was successfully mounted on my new MacBook Pro. I set it up as Time Machine backup, and even though the first data transfer was successful, Time Machine got stuck with a “waiting to complete first backup” message. I ran Disk Utility to erase it and try again, but it got stuck during the erase process. After re-connecting it to my old MacBook, I was able to erase it without any issues. So, it looks like these issues are specifically related to Monterey, and even though changing the partition type to APFS helps (on a different system), it does not resolve the issues completely.

I suppose all we can do now then is to wait for Apple to issue an update to Monterey 12.0.1 which fixes the problem.

I agree, waiting for Apple or WD to issue a fix seems to be our only alternative. My trouble ticket to WD has resulted in only a scripted response telling me to check my USB cable, make sure disk is formatted correctly and to run Apple Disk Utility and First Aid with a request of a screen shot of the results. WD paid no attention to the facts I gave them that the disk will not mount after upgrading to Monterey. Apple just refers you to WD.

Thank you lpjakob, saves the rest of us having to go through the same process.

Same problem with the G-Drive USB Mobile, the problem is with the cable. I upgraded to Monterey and the drive would not mount, used another USB-C to USB-C cable and it mounts with no issues.

Kevin91, good news, I just received a notification from WD that they are aware of the problem and they are working with Apple to resolve. See link below that WD provided to this problem. I have already responded to WD advising that the same problem is occurring with Macs that have the Intel CPU.
https://support-en.wd.com/app/answers/detail/a_id/31963

I have this issue, and it’s on an Intel iMac from late 2020. I have two G-DRIVE mobile USB-C external drives; one 2TB drive is used for Photos, while the other (4TB) is a dedicatewd Time Machine backup drive. The Time Machine drive will not mount, unless I use an Apple USB-C charging cable — which is not a fix, since the data transfer rates are horrid.

I followed the link above, and it still only reflects that WD believes the issue only affects M1 and M2 chipset Macs, but this is clearly not the case. The guy I talked with at WD support (I arranged to return my disk under warranty) was only aware of the issue affecting the M1 and M2 Macs.