Mac Can't Read Replacement Disk in G-Raid TBolt3 configured to RAID 1

Have a G-RAID 16TB Thunderbolt 3 array configured to RAID 1. Had been using the array successfully for a couple years, then it got very noisy (fan problem?) and WD replaced the chassis and seemed to be working with both original drives. However, soon after got the dreaded red light on one drive, while the second drive continued to work alone in the chassis. WD replaced the one drive, and I inserted the replacement drive and left it for 24 hours thinking it would automatically rebuild 4T of files – but it did not seem to rebuild as far as I can tell? Now when I insert just the replacement drive in the chassis by itself, without the good drive, I get the message that the “disk you inserted is not readable by this computer.” Tried “First Aid” on the replacement disk, and that didn’t help. My original good drive is still working, both alone or when the replacement drive is also in the cassis. Not sure if this is a problem with settings, some missing step I need to undertake, or a further drive problem or chassis problem? One thing is for sure – any steps I take must not mess up the one working drive if at all possible, although it is backed up elsewhere. HELP?!? Screen shots attached. Thanks! Don

Hi @Fishindon,

For more information, please refer to this KB article: G-Technology RAID Configurators and Utilities

Neha, Thank you!! Your info is helpful and I am looking into things based on it. But I have further followup questions if you don’t mind, RE: your last sentence . . .

I should also tell you, I am actually having similar questions about TWO different G-RAID arrays, the one I mentioned in my original post for which one drive in the chassis has been replaced but the replacement is not working . . . and a separate brand new G-RAID Array which I tried to set up for RAID 1 but where RAID does not seem to be working. In both cases I am wondering if I properly set up RAID 1.

I am now running macOS 10.15.7 – does this explain why originally I do not have a RAID option on Disk Utility? (That’s why for my NEW Array I instead originally found and used a "G-RAID with Thunderbolt Configurator " option which I had downloaded. I am not sure how I thought I set up RAID 1 on the OLDER array which I have been using for several years until a drive was replaced.)

I found a couple of 2018/2019 articles on your database/community which talk about using the same “configurator tool” to “rebuild” a failed drive – are those explanations outdated and no longer valid?

Before reading your answer I began a process of “rebuilding” RAID 1on the NEW/UNUSED G-RAID array using the same G-RAID configurator since it showed one of my drives as “degraded” – will this rebuilding accomplish anything or hurt anything?

You mentioned that I can still manage Software RAID drives “via the Terminal,” but I do not know what you are referring to – what do you mean by the Terminal and how do I use it?

Assuming I need to now attack this problem using the “Terminal” or SoftRAID, on my OLDER G-RAID array, will I be able to fix the unreadable replacement drive without screwing up the original good existing drive? Separately, on the NEW G-RAID Array which I am trying to set up, do I first undo anything I have already done because of using the “configurator” – for example, do I need to use an option such as First Aid, Erase or Restore before I try to re-set up RAID 1 using the “Terminal” or SoftRAID?

Thank you again so very much!!!
Don