m2ts container subtitles issue


#1

please can someone tell me how did he/she manage to view subtitles from m2ts ?

i have a backup of a bluray (AVC with DTS) and the embedded subs don’t work

thanks


#2

Can you tell me how your WDTV is set up?  Are the M2TS files on a local attached drive, or are you trying to access them over your network?  

If they are over your network, are you using network shares or Media Server?

Are you able to place the files on a local attached drive and run the file correctly with subtitles displayed?


#3

thanks for reply, it’s a vc-1 blueray 1080p with embedded subtitles on an attached passport hdd. First of all as long as wd live doesn’t support for now bluray menus the subtitles are not selectable. I go in the stream directory select an m2ts file and does play it but inform me that there’s no subtitles. On pc selectable from bluray menu


#4

The subtitles should work.  If you go to settings > System, is your additional encoding support set for your subtitle language?

What is your subtitle language?


#5

when i tried the movie all settings were set to default, and the subs are in romanian


#6

You will need to change the encoding support.  Default is Western Europe.  If you go to Settings > System Settings> additional encoding support.   Then try 1 of the 2 Central Europe encodings and see if your subtitles are displayed correctly.


#7

Sorry that I’m joining to this thread but I have the similar problem. Unfortunatelly my WD TV Live doesn’t recognize subtitles in blu-ray files (m2ts). When I want to choose the sutitles in Options It only communicates that NO SUBTITLES (are availible). I’ve changed settings ( additional encoding support) several times, but It doesn’t work. Is it possible to watch the m2ts files with subtitles? If not, is there any other option to watch blu-ray movies on WD with subtitle. If not (again), do you plan to change that in the future e.g. together with the next update?

I forgot to mention that I had the same problem with one of my DVDs (vob files). In that case I burnt the files on DVD-VIDEO disc and then I made an iso image. Now it works fine. Unfortunatelly I cannot do the same with blu-ray cause I don’t have Blu-Ray rewriter.


#8

the thing is… ive tried my .m2ts to my friends wd tv live and subs are working just fine… then i bought my own wd tv live but the subs wont work. its the same video file and i dont understand why it wont show. it has the other audio though but subs are nadda


#9

Welcome to the forums.

What firmware version are you running?