M.2 RMA Process Request


#1

my drive just recently quit on me … got the drive is dead screen after trying to boot it up … been trying over 2 weeks to put an RMA but the website doesn’t allow me to verify my address? even though i have register it and made a previous RMA over the phone before… website RMA is bad looked up WD RMA Billing address verify and you will see this is a known problem trying to do a RMA on their website . i tried calling and that went horrible … there was a major language barrier . had an RMA but that RMA was set for a hard drive ? even though i said m.2 NVME drive … hope to get this resolve and have my computer up and running sometime soon


#2

Hi Joseph-C.

Please check your private message.


#3

saying like other articles it is how i type my address… i copy from my statement 100% and it’s still wrong …
article like I'm trying to create a RMA , I'm trying to create a RMA , RMA - Not able to sumbit address
still unable to do a RMA for a boot drive i can’t use anymore …


#4

issue still not solved


#5

was also told that they tech support can’t help me on my dead drive … so i paid a drive that tech support can’t help me because Advance RMA says my address is not verified -_-