Lots of videos play in fast motion

Originally the thread was titled “where is the match video framerate option” because I was trying to fix a problem with videos playing in slight fast motion.  Well I found it and it didn’t help.

Now I’m noticing a lot of videos play too fast.  Any known fixes for this?

Some facts:

  • WD TV Live Plus
  • Latest firmware
  • Using TVersity (after hours trying to set up windows media sharing I gave up and just installed this, but had to use an old version because the WD device wouldn’t work with the latest version)

I see people say they revert their device back to 1.0 to fix a problems but I see no option to do that.  How is it done?

Here is the original post: 

A video was playing in slightly fast motion.  Audio and video were in sync but its in fast motion.  Not super fast but enough to be extremely distracting.

Googling around, it seems checking “match video framerate” option will fix it.  Problem is I don’t see that option anywhere.  I just got it today so I’m sure that has something to do with it.  Any ideas?

Also, in the same google’d posts I’ve seen people say “just set it to 24p” and talking about 50p and 60p…what does all this mean?  Do they mean hz? 

As you found out, there is a problem with auto framerate with the latest firmware. If you want to roll back to an older version, use this link:

Firmware Rollback