Lost write permissions in Win 7

I have a 3TB WD external hard drive that I have had connected to a Win 7 computer for a year. I have always had permissions set to read and write to it and have created folders and written files with no problem the entire time. Suddenly, I am unable to write to this drive on my Windows 7 computer (but it reads just fine). The option to create a new folder is not present. I CAN however, read and write when I connected it to my Windows 8 computer. Any help would be greatly appreciated.

Hi llcamino,

You should have a look at the link given below.

Thank you alex.singh but this is not the problem I am having. When I select the WD External drive and open it to view it’s folders, the toolbar no longer shows “New Folder” as an option next to “Organize, Include in Library, Share With, and Burn”. Right clicking on a blank space with the drive no longer gives the option to create a New Folder.

I am also unable to copy any files on the PC’s internal HD onto the WD External Drive.

I have now tested this on 2 Windows 7 machines and confirmed that the option to create a New Folder (or write in any way to the drive) is gone in Windows 7. However, full writing permission works in Windows 10.

Hello!
I’d like to join to TS with the same problem happened with mt MB 8TB WDBBGB0080HBK. After reinnstalling Windows 7 I lost full control to the device, and it’s read-only for this moment. I cannot create, delete or rename files and folders. There is also no more “Security” tab in drive/folder Properties, and no more Cut, Paste, Delete options on the right click.
The drive is working fine on my laptop with Windows 8.1 installed. I’ve got full access and create/delete/remane files or folders. But in Windows 7 I have nothing.

My suspicion is that somehow when connecting to a Wondows 8 or 10 computer, it changed some setting which is not compatible with Win 7.
Fortunately I decided it was time to ditch windows 7 on my last remaining Win 7 computer and I upgraded to Win 10. Problem solved. By the way you can still get the free upgrade to Windows 10 until January 16th. You just have to go through the links to get the “Accessibility Version” of Windows 10.

I also heard about this free upgrade to Win 10 un til Jan 16, but problem I have is that my motherboard is not supporting buy Windows 10 and cannot be upgraded.
That’s why I’m still using Win 7.
Today I collected some external hard drives from my friends and now copying all stuff to these drives, and after that I probably will try to format my WD in new systen installed.
But I’m still hoping to solve this problem.