Lost username/password. Help!

I’ve just bought a new WD mybook and have managed to lock myself out of the website setting bit. The configure, map drive. Etc. When I click the WD web page to configure the drive it loads the drive website type thing where you can change settings, etc. But everytime I type in what I think is my username and password it seems to add a few letters to the password when I press the login button and the comes up with invalid username/password.

Can anyone help???

yeah… theres like 8 my book drives with smartware and 10 others that are a network drive… can you specify which one you are using?

i would suggest checking out the “User Manual” first…

check this link out;


The External Drive is a My Book World Edition 1TB edition. The Website comes up when I click WD Discovery Software. I click on the WD Discovery and get this website

http://xxx.xxx.x.xxx/index.php etc. It asks me for a Administrator Name, Password, Tool and Language and you then log on.

However since the last time I logged on it won’t let me log onto this website again… Everytime i enter my username and password it comes up with error. I’ve tried admin/admin and what i entered before. But everytime I enter the password and press login it seems to add extra characters and comes up with ‘administrator name and password entered is not correct’

I’ve tried to reset it as the manual says. Is there any way of getting into the software, etc.

The MBW White Light user name and password is admin. If you tried and is not working then a reset should revert the password to the default one. 

To reset just press and hold the reset button for 4 seconds until the unit reboots. 

Looks like you changed the password the first time you logged in.

Don’t worry if when entering the password it adds a couple of characters that’s normal on the MBW.

1 Like