Lost sound completely + loose network setting after every reboot. Do I simply get a RMA?

Unit was working OK, will loose network setting after every reboot but found the get around which is press submit in the workgroup section.  But all of a sudden I lost sound completely.  Did reserach on this forum tried resetting box, unplug unit, restart unit… still no luck.  Do I simply have a bad unit??? any suggestion would be great.

Try different audio settings and different cable

Tried changing cable & different audio settings without success.  Finally got it working again after disconnect the box from everything, power cord + HDMI + ethernet and left it for more than 30 mins.  Plug everything back and do factory reset.  Now its working again…  But seems like the unit will just go wild every once in a while.  Is it normal??  Do I need to RMA the unit??  Please help

What were you doing before you lost the audio?

Had anyone accessed the SMP remotely, such as using the play to feature in Windows Media Player or using a Android remote app?