Lost sight of some movies

Is there a limit to the number of files that can be seen and/or the number of sub-folders? I have connected a 2Tb Buffalo NAS and it has been working well. I have already watched one of the movies in a sub folder, but have since added more moives to the NAS. Tonight, I tried to find that same folder but it can not be seen by the WD TV Live Streaming unit. I can see the folder on the NAS via my PC.

I removed the and readded the NAS under the Network Share manager - forcing a full rescan, but no change.

Any help?


PS just checked all files and it seems there are several folders (that I have previously seen and played movies from) that are now not showing up.

Well still no change - tried moving the dir up one level before going to bed last night (hoping it would rescan at some point) but no joy.Movies can play from NAS on the PC so they are not corrupt.

Trying to narrow this down - has anyone seen similar?

Will try deleting and re: copying over to NAS, but as this dir has 10G (and as I said ther seems to be several dirs in same position) I don’t want to start doing this on a regular basis!

Please help.


Well, was holding of on trying the obvious until someone replied. But have tried moving one of the folders elsewhere, then copying it back into the folder where it can’t be seen.

But this did not work - the folder can not been seen where it was moved to - and the copy I made (back into the original folder) still can not be seen. I’ve looked at permission/properties etc and all looks the same as other movies.

I’ve copied all my music and all my stills. But it is gonig to be harder to recognise if a still or home video is not present than it is to see a movie is not there - so before I move all my content I’d like to understand what is going wrong.


The only thing I can think of is that it’s something to do with the parts of your NAS you’re telling the SMP to look for in your Media Library.

Have you tried deleting all of these and starting again?

Are the films not visible under Media Library, network shares, or both?

Steve W

The films are visable via the PC. All the films had been visable and some played via the WD unit. I removed the association with the NAS completely then added it again and waited as it rebuilt the complete library, but still can’t see the films it had seen before.

To connect I simply went to network share and selected the NAS as it showed up there.

The NAS just has one folder [Share] that everything is in then folders Movies, Music, Photos under movies folders kids and general, under general there is Action, comedy, Drama under comedy there should be two more folders but there are none! Under action there should be 4 folders, yet there are only 2!!


Problem solved - I’m just not sure I fully understand.

So what I figure is: if the WD unit is linked to a NAS it can compile a lib. If the WD unit ‘looses sight’ of the NAS but the NAS is still on the network the WD unit will still be able to play movies in the lib [as the lib holds a link to the movie]. If in this state a file in renamed or moved to a new folder that new name can’t be added to the lib nor can the lib see the new folder as it has ‘lost sight’ of the NAS.

I don’t know how this happened or at this point how to avoid it happenening again - can anyone set me straight on this. Do I make sense???