Lost partition on WDT-D2B


Got a portable WDT-D2B 1TB portable drive that suddenly became inaccessible in Windows and also other media

player device that understands NTFS.

Windows Disk Management can recognize the disk as:


931.51 GB

Not Initialized

The partition is Unallocated and the disk is also write protected.

I have tried Remo Recover using Recover Photo option but nothing has been found at all.

While connected to my Windows laptop, the WDT-2DB LED is slow flashing, ie alternating between on and off for 

about 2 seconds each.

I really want to recover all the data from the disk first before considering reformatting. Can you please kindly provide

assistance ?

I forgot to mention I have also tried testdisk-6.14 to scan for lost partition but during the entire process I see 

Read error at C/H/S.

I have the screen capture if there is a way to attach to the message.

HD Tune disk info:

HD Tune Pro: WD      Elements 1023    Information

Firmware version : 01.01A01

Serial number    :      WD-WXD1A4117554

Capacity         : 1000.2 gB (931.5 GB)

Buffer size      : 8192 KB

Sector size      : 512 bytes

Standard         : ATA8-ACS - SATA II

Supported mode   : UDMA Mode 6

Current mode     : UDMA Mode 7

Avergae speed    : 61 MB/s

Rotation speed   : 5200 RPM

S.M.A.R.T                    : yes

48-bit Address               : yes

Read Look-Ahead              : yes

Write Cache                  : yes

Host Protected Area          : yes

Device Configuration Overlay : yes

Firmware Upgradable          : yes

Automatic Acoustic Management: no

Power Management             : yes

Advanced Power Management    : yes

Interface Power Management   : yes

Power-up in Standby          : no

Security Mode                : yes

SCT Tables                   : yes

Native Command Queuing (NCQ) : yes

Trim                         : no

HD Tune Error Scan reported the following:

HD Tune Pro: WD      Elements 1023    Error Scan

Scanned data   : 163 mB

Damaged Blocks : 100.0 %

Elapsed Time   : 0:10

1  Error at 0 MB (LBA 0)

2  Error at 0 MB (LBA 128)

3  Error at 0 MB (LBA 256)

4  Error at 0 MB (LBA 384)

5  Error at 0 MB (LBA 512)

2496  Error at 155 MB (LBA 319360)

2497  Error at 156 MB (LBA 319488)

2498  Error at 156 MB (LBA 319616)

2499  Error at 156 MB (LBA 319744)

2500  Error at 156 MB (LBA 319872)

ie 2500 Errors. But only first two blocks are marked red as Damaged and the rest of the disk is unchecked and left in

grey. Is the MBR damaged ?

Quick scan shows different visual results that  it stops at:

Scanned data   : 500 gB

Damaged Blocks : 100.0 %

Elapsed Time   : 0:10

and all blocks up to 500gB marked as red … :frowning:

Is it possible that the encloure/case with the USB to SATAII converter chipset is at fault here instead of the actual

disk gone bad ?


Hello, I’m not sure if they will work, but you can try using recuva or testdisk to recover your files, also check if using another USB cable helps. 

Sometimes booting from a Linux Live CD allows access also.