Lost Network Shares

I have been running along happily with my WD TV player for a week or so, but all of a sudden it lost the network shares.

When I go to set the network share again the orange arrow circle just stays up and it never finds anything.

  1. Files will play through the Media server option

  2. The network is connected when it is checked

  3. Internet apps work

  4. My shares are visible to other computers on the network.

Unfortunately, the best way to play certain files is via Network Share (some do not even show up under the Media Server).

I have tried the suggestions in:


I have scoured this forum for suggestions.

The one thing I can think of is that I ran a Ccleaner cleanup on my computer where the shares reside. I was thinking it may have deleted the files mentioned in the link above. However, the actions had no effect. 

In my advanced Sharing options in Win 7, I have Turn on password protected sharing selected, but The WDTV is allowed everywhere. When I enter a username and password in the WDTV for network shares it still fails. When I turn off password protected sharing on the WDTV it still fails. Do I need to match some settings here?

If anyone has an idea of something I should check, I would greatly appreciate it.


Have you tried a power cycle and/or a reset on your WD TV?