Lost Folder on menu of Easystore ED 8 TB

The Folder “Pictures” which is/was a folder of “I believe” over 8000 photos/videos and about 200+ GB stopped appearing on the external drives menu when I pulled it up the other day. I have tried everything “search”,etc. without results. I don’t believe I deleted it since it had all my photo/video collection over many years. I have a back-up which is several months old, but need to do everything to re-coupe the current folder because of all the photos/videos I have added since that old back-up. Please help? Thank You, Gary


You need to supply some more information. Review some articles in WD Support for guidance if you haven’t.

Computer type and operating system used.
Type of backing up: Copy/Move and Past; software name if used.
Type and name of your external drive.

USB connection type and have you tried an alternate.

You should also consider using a Data recovery service.

In the future do not depend on one backup device.


Cliff, Here is the info you requested:

  1. External Drive is a WD Easystore, P/N: WDBCKA0080HBK-NA, S/N: 7SGHDDJC
  2. Computer is a HP TouchSmart 600 All-In-One running Windows 10 Home
  3. I do not use the external drive with backup software. I copy/cut and paste all files and folders from whatever computer it is connected (all running Windows).
  4. I use the USB connection to any computer I’m connecting the external drive to (I unaware of the type of USB connection each computer has that I’m connected to including currently my Touchsmart).
    Finally, I just tonight lost another Folder “My Reading” when I was trying to open it with my mouse.

Hope you can give me some more advise with this info.
Thank you for your reply,


I do not use Cut/Paste so I’m not expert, but Windows 10 should be just treating the external drive the same as an internal drive. I can’t really say what is causing the loss to your external file.

I work with a small C: drive and 1TB partitioned internal drive. I backup (copy/paste) to the 1TB partitioned external drive using WD Backup software and have no problems.

The only thing I can suggest is that you download a copy of WD Drive Utilities and run the Diagnose checks. DO NOT ERASE THE DRIVE. Maybe some other users will post here with additional help. You can also go to the Support group and open a Support case for Tech help from WD.


I solved the problem. I found “My Reading” inside another folder that shows on the external drive’s main menu of folders and files. I then went through all the other folders and found “Pictures”. It appears when moving my curser up and down the ED’s menu I “caught” and dragged the folders into another folder and they disappeared from the main menu. Simple solution, but pretty dumb on my part.
Sorry to bother you and thanks again for your comments to try and help me.