Lost external USB storage after updating to new Firmware 2.08.13

As the title suggests, after following the prompt to update the firmware to the new version, 2.08.13, the WD TV Live Hub hung after re-booting last night.

I found that when I disconnected the external USB HDD (1TB) the WD TV Live Hub booted to the GUI, but when I re-connect the USB HDD again the unit hangs.

I performed a CHKDSK on the USB HDD from a Windows 7 laptop and this corrected bad clusters but I am still unable to connect the HDD to the Hub?

I’ve performed a RESET using a paper clip, deleted the .wdtv folder from both the internal and external storage but still to no avail!

Any suggestions would be more than welcome and Thank You in advance!

I’m having exactly the same issue.

After installing the new firmware the device re-booted and hanged reading the USB drive (WD light was blinking). After waiting for a long while, I powered it down and on again, and then it finished booting. I did not have to unplug the external drive, but it was not recognizing it anymore. The internal drive is working fine. 

Most of my media is in the external drive. 

I’ve rolled back the firmware to 2.07.17.

This now allows the Buffalo 1TB HDD to be attached to the Hub (using either of the USB ports) without causing it to hang and can be seen and accessed on the network but annoyingly still not visible by the Hub.

I’ve submitted a ticket to WD support and await their response, which of course I’ll keep you updated.

I think that I may delete the media library and let the Hub re-build this in the hope that it will see the external storage, but this may be the last option.

I’ve turned the Media Library off and rebooted the Hub and then turned it on in the hope that this would allow the Hub to see the directly connected USB storage, but alas the storage is still not visible.

Any suggestions from the community would be welcome since WD have not given me any useful assistance since I openerd a ticket on Sunday 10 October.

(Some of these steps may have already been tried, so pardon any duplication…)

  • Fully shut down the Hub  (3-second power button trick)

  • Remove the USB disk from the Hub and attach to a PC.   Do an error check via the Windows Explorer menus.  Don’t worry about a surface scan.

  • Browse into that disk and delete *ALL*  .wd_tv folders and their contents.   Use SEARCH to find them; there may be some in subfolders.

  • Boot the hub WITHOUT the USB disk attached.


* Turn OFF Mobile Media 

* Turn OFF iTunes Server

* Turn OFF Media Library

* Turn OFF Twonky

* Turn ON the WD LED control.

Plug the USB drive in.   It should be recognized and active within about 30 seconds.  Confirm this AFTER the WD Logo stops blinking. 

If all is well:   Go in the REVERSE order and turn what you need (and only what you need) back on.

At what step do things go awry now?

Many thanks for your contribution but the solution I’m afraid, as with most things, was in plain sight!

When the firmware was upgraded to 2.08.13 the unit must have been set to factory default.

The resolution to viewing/playing an external USB storage was the following:



Select  top right hand icon (red ) - Content Source


Select  ’ All Local Storage ’

Voila - All sorted.

Hope this helps others

I updated to 2.08.13 and like many people my WD external 2TB USB drive was no longer there.  After doing some checking, WD say you must disconnect any/all USB drives before applying the update (which I did over the internet using the live update feature built in to the unit).  Of course there was no warning when doing the live update, I only read the USB warning after looking online.  In any case, I formatted my drive (luckily I backup all of my drives, so I had a copy of what was on the drive) and reattached it to my WD Live Hub (2.08.13) and bingo, it saw the drive and I was able to resync all my media back over.

So, in short, if you had your drive connected when doing the update, you will likely have to re-format the drive on a PC and then attach it to you Live Hub again. There may be other, less drastic ways to get things going again, but this worked for me.  Hopefully this helps some people out.

I have had this happen to me on several occassions without upgrading any FW.  My attached 1TB WD will one day just not be recognized, I plug it into my PC, gives me message I must reformat drive for it to be used.  Fortunately I can run a recovery app and restore all of my movies before reformatting…very annoying

Could you please tell me how to roll back? 2.08.13 is giving me problems to play content located on external USB drives. PLEASE !!!

I found a procedure to roll back to a previous firmware version. Never mind.

Having the same problem here after 2.08.13. Basically my HFS external drive would mount, but trying to browse it will give the “There’s no media in the current folder” message. Deleted .wd_tv hidden folder and still nothing. I did some more testing and here’s what I found out (hopefully this information will be of use to some of you)

  1. Problem seems to be related to the Media Library. Turning it off lets you browse the external drive and copy files just fine. Resetting the Media Library also works, but you lose all your content info and resume playbacks but I could browse the external drive and watch media off it again. Cover artwork are all intact after a reset.
  2. If turning Media Library off doesn’t let you browse the external drive (see below), try restarting the device (it’s worked consistently for me so far).
  3. The trigger for this glitch appears to be when you try to delete or move a file  (which is really a copy and delete) from a HFS volume via WD TV Live Hub (I only have a HFS external drive, I don’t know if this is the same for other file systems). The “failed” deletion attempt seem to hose the Media Library in some way and cause the external drive inaccessible by it. I’ve done this a few times with consistent outcomes after several Media Library resets.

Very dissappointed with the recent firmware update. I hope the next update fixes this glitch or improves things, otherwise this is the last WD product I ever buy or recommend anyone.