Lost directory after update to MyOs5

After updating WD my cloud from MyOs3 on MyOs5 cant find root directory “Foto&Video”. Other directory are OK. Even after logging into the administration, the directory is nowhere to be found.
Disk capacity remained the same.
How can I restore access to the directory and especially the data?

Do any other Shares use the “&” character in the name? If not, that may be the cause. You may need to access the My Cloud using SSH and locate the missing Share and check it’s permissions and user/group ownership to see if it matches or is similar to other Shares. If the Share name is the issue due one can try renaming the Share through SSH and see if the Dashboard recognizes the renamed Share.

My Cloud: Access Using SSH (Secure Shell)

Thanks a lot - ssh works and directory is there. Only this dir is with “&” character in the name.
I rename folder, but dont know how change share. Directory “FotoVideo” isnot mounted in shares.

root@WDMyCloud shares # ls -l
lrwxrwxrwx 1 root root 19 Jul 9 13:27 Filmy → /mnt/HD/HD_a2/Filmy
lrwxrwxrwx 1 root root 20 Jul 9 13:27 Public → /mnt/HD/HD_a2/Public
lrwxrwxrwx 1 root root 23 Jul 9 13:27 SmartWare → /mnt/HD/HD_a2/SmartWare
lrwxrwxrwx 1 root root 31 Jul 9 13:27 TimeMachineBackup → /mnt/HD/HD_a2/TimeMachineBackup
lrwxrwxrwx 1 root root 13 Jul 16 10:14 Volume_1 → /mnt/HD/HD_a2
lrwxrwxrwx 1 root root 20 Jul 9 13:27 WDSync → /mnt/HD/HD_a2/WDSync
lrwxrwxrwx 1 root root 18 Jul 9 13:27 moni → /mnt/HD/HD_a2/moni
lrwxrwxrwx 1 root root 17 Jul 9 13:27 non → /mnt/HD/HD_a2/non
lrwxrwxrwx 1 root root 21 Jul 9 13:27 tesprok → /mnt/HD/HD_a2/tesprok
lrwxrwxrwx 1 root root 19 Jul 9 13:27 vsedl → /mnt/HD/HD_a2/vsedl
root@WDMyCloud shares # cd Volume_1/
root@WDMyCloud HD_a2 # ls -l
drwxrwxrwx 17 root root 4096 Jul 10 16:57 Filmy
drwxrwxrwx 40 root root 4096 Jun 29 18:33 FotoVideo
drwxrwxrwx 4 root root 4096 Jun 29 22:27 Nas_Prog
drwxrwxrwx 10 root root 4096 Jun 29 22:32 Public

Have you tried rebooting the My Cloud to see if the missing Share comes back after booting up?

Edit to add: If the missing Share doesn’t come back after rebooting then its possible one may have to check the Shares that are listed in /mnt/HD/HD_a2/ and see if they are symbolic links to the Share location in /Volume_1/. If so then try creating a symbolic link (with the same permissions and user/group ownerhship as other entries) in /mnt/HD/HD_a2/ to the FotoVideo Share in /Volume_1/.

Rebooting doesn’t help. I Don’t know how it works and what is the right way to mount directory “Foto Video” to shares.
I tried:
root@WDMyCloud shares # ln -s /mnt/HD/HD_a2/FotoVideo /FotoVideo
root@WDMyCloud shares # ls
Filmy SmartWare Volume_1 moni tesprok
Public TimeMachineBackup WDSync non vsedl

As previously indicated one may have to see if the Share entries in the /mnt/HD/HD_a2/ folder are symbolic links. If they are then one may have to create a symbolic link to the missing Share.

Another option is to create a new Share through the My Cloud Dashboard > Shares section, then using SSH, copy/move the contents of the “missing” Share to the new Share.

In certain cases a 40 second system reset can fix certain issues. Perhaps a 40 second reset could potentially fix a missing Share.

My Cloud OS 5: Pin Reset & System Only Restore

1 Like

Thank you very much!
The second option with copying to an existing new folder was safe and everything is already working.