Lost connectivity following IOS release/firmware update

Hey everyone, I lost connectivity with my 3TB my cloud a while ago. From looking at my time machine backups it would appear that the my cloud hasn’t been connected since last backup on october 2nd. coincidence IOS release was 3rd? Anyway I’ve tried the very limited knowledge that I have to try and get the drive connected again. I have a lot stored on the drive which I’m very precious about retrieving from it. Is there a kick start anyone can suggest? each time i try to connect using WD software i get an error stating “unable to verify firmware”.

First, take a look in the web interface of your My Cloud if everything is OK. Opening the web interface is http:\\wdmycloud for example.

If you updated your Mac to El Capitan and you face problems with Time Machine, please delete the mounted disk, your My Cloud, within Time Machine and mount this disk again - El Capitan seems to have massive problems here.

Hi, thanks for your reply. Completed all as you suggested and still no connectivity at all. I have purchased a dock now to try connecting this way, in order that I can data recover all my precious family photos etc.

What color is the LED on the front of the My Cloud, provided you haven’t already removed the internal hard drive from its enclosure?

If that LED is blue then it should be accessable by the Mac Finder or via a web browser. If white then try a 4 second or 40 second reset to see if the problem clears. See the following WD Support document for more in formation on how to reset the My Cloud: http://support.wdc.com/KnowledgeBase/answer.aspx?ID=10432 If the LED is red that typically means something more serious has happened to the drive.

Edit to add: As was previously indicated the Apple El Capitan update is causing several problems with user’s ability to access and use their My Cloud devices. There are numerous other threads discussing the various issues with El Capitan. Here is one of the many threads:


Hi Bennor, the light has remained steady blue, only time it has been any other colour was when I completed the 40 second reset and at that stage it flashed white. Even after the 40 second reset connectivity still not possible.

No connectivity at all? Nothing? Not even the Dashboard?

Have you tried finding out your device’s IP address from your router, and accessing the Dashboard using the IP address?

Do you have any other devices you could use to access the device? Phone? Mycloud app? Android device and file manager, using smb network access? DLNA client? Just to see if the MyCloud is basically working, and confirming your problem is ElCapitan as we suspect?

No connectivity at all, not even dashboard.

Haven’t tried finding the IP yet on my network, must give that a go.

I have the WD apps on iPhone, iPad and can’t connect to it via them either which would rule out el capitan?

Lack of access via the app would seem to rule out El Cap, yes…

The other thing that happened around October 2nd was the OS3 firmware upgrade; that may have caused some confused state. Or had it already upgraded?

What are the network LEDs doing? Although if the network was down, you should get a yellow front panel light.

May be time for a power cycle reboot. It could take a long time (days, even) if it has to do a disk check/recovery; flashing white light.

I attempted to upgrade the firmware and then lost all connectivity around start of october. from memory I think the network led’s weren’t that active. light on the front is steady blue.

How do you go about a power cycle reboot? and would I loose any data?

Thanks for all your help and knowledge, I really appreciate it!

How do you go about a power cycle reboot? and would I loose any data?

IT Support Response #1: Have you tried turning it off and on again…? :wink:

Unplug the DC power. Wait for a minute or so. Plug power back in.

You shouldn’t lose any data; after all, the device really ought to be able to cope with loss of electricity supply (no electrical power distribution grid is infallible). But, as your device seems to be playing up, it’s hard to say; you may already have lost data. Normally, you would shut the device down from the Dashboard before removing power, but as you can’t do this, you’re a bit stuck.

If there is a problem with the file system, you are likely to see a flashing white light for a long time; this is the device performing a file system check (fsck). If it comes up blue, then the device ought to be happy, and you ought to be able to access it. But…

[edit: just spotted you’ve already done a 40 second reset, which involves removing power. So you’ve already done a power cycle reboot. I think I’ve come to the end of my suggestions: time to raise a Support job, I think.]

[edit2: one last thing: have you tried rebooting your router?]

Hey, yea I have rebooted the router several times. I contacted WD several times via email and the help provided has been very generic in response. I’m convinced the firmware update has caused this failure. I also had a look in my router settings and the 3tb drive doesn’t appear at all, my other 4tb my cloud does appear and i can see its IP address, which is even more infuriating.

Yes, I suspect the firmware upgrade has resulted in some semi-functional state; thinks its okay, so blue light, but not actually talking to anything.

There’s something niggling in the back of my mind about this… Sure I’ve seen previous report of the Ethernet comms dying silently. That would explain the no router visibility, no dashboard, no access, but blue light.

Just for completeness; try a different cable & router port?

I have changed over router cable with the drive thats working. The working drive has continued to function as normal with the cable from the drive thats lost connectivity, so not a cable problem, however the drive that isn’t connecting now has a blue flashing light on front.

Blue pulsing (fading up and down, rather than abrupt on/off) means it’s gone into standby…

There’s no valid code for abrupt on/off flashing blue (p10 user manual).

Change router port…? I’m not hopeful, but let’s try it…

What happened when you unplugged the network cable. It should have shown flashing yellow.

sorry forgot to mention port was changed at the same time as cable change also. the front led has stopped flashing.

I’ve run console on my macbook, it appears the my cloud is attempting to communicate with my mac but there is just something not quite clicking together.

As I said on your other thread, this is not your mycloud talking to your MAC. This is WD Sync running on your MAC, trying to find a device it is configured to sync to, but failing to find it (getting no response), and continuously retrying.

“‘WDMyCloud’ could not be found on the network. Will try again in 120 seconds.”

What are the network connector LEDs on your MyCloud doing?

What does the front panel LED do if you unplug the network cable?

When disconnected from the network front led continues to light steady blue whereas my other drive when i disconnect i get a flashing white light. When connected to the network the connector led’s amber on constant green flashing.

When disconnected from the network front led continues to light steady blue

That shows that there’s something not right with the Ethernet port on your MyCloud; it’s not detecting presence/absence of a network connection. That’s the cause of all your problems. As to why the port is faulty…? Faulty hardware? Faulty driver installation in the firmware upgrade?

whereas my other drive when i disconnect i get a flashing white light.

It’s probably flashing yellow: ‘Attention: Network cable not inserted’. That’s what I expect to see.

I see from one of your other threads that you have opened the case and removed the hard drive, and placed it in a caddy. It looks like you might need to concentrate your efforts on rescuing the files and attempting to re-install the firmware (de-brick).

A quick google suggests there are tools for the Mac to allow you to read an ext4 formatted disk. Writing seems more troublesome…

1 Like