Lost connection on re-boot

#1

Hi
I recently had to rebuild my pc, full Win 10 reinstall etc.

Every time I start PC and log on I get Windows telling me could not connect to network drive. I resolve this by:

  • opening explorer and disconnecting the network path (shown with red cross) to my WD My Cloud device.
  • right click WD Quick view , select my cloud device name, select map and re-map. The reconnect next time tab is ticked.

It works. When I switch off and reboot I have to go through that again! This was not an issue before rebuild.

Device home page opens fine and firmware upto date.

Apart from installing smartware I didn’t do anything specific for the cloud device when rebuilding like installing it. Its connected to router so was ‘just there’ as I focussed on rest of devices and software.

What steps can I take to correct this and have to nicely mapped everytime I reboot ?

Many thanks
DJ

#2

Map the drive using Windows ‘Map Network Drive’ function instead?

Make sure you check the ‘connect as different user’ box, and enter your MyCloud credentials.
Make sure to tick the ‘re-connect at login’ box.

#3

Thanks for reply.

After a reboot and faced with couldn’t connect network device from windows I tried the windows map function but under network the cloud wasn’t showing for me to select.

I’d always had re-connect ticked but not the connect as different user. So clicked latter and entered details. cloud showed under network. Rebooted and it was gone again.

The one thing I noticed previously is that the WD smartware shortcut to mapping the drive via ‘quick view’ doesn’t work unless I have first opened the WD smartware program. When first opened the home screen of that shows a red cross over my cloud device then after a second it goes. then the shortcut via quick view works. Its almost like the smartware program is making the device available.

#4

First make sure to install ALL Windows 10 updates.

Second you may want to review the following thread which has a bunch of Windows 10 specific suggestions when it comes to the My Cloud.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

Third, make sure you are only using one set of My Cloud Dashboard created credentials when mapping multiple Shares from the My Cloud.

Fourth, make sure to assign the My Cloud a static IP address. Sometimes if the IP address changes the drive mapping may be broken.

Fifth, when mapping the Share make sure to select “connect at sign in”.

Every once in a while I get a cannot reconnect mapped drive when the computer is started or rebooted. Usually just clicking on the mapped drive in Windows File Explorer is enough to fix the issue. I suspect that what is happening is that Windows is attempting to connect to the mapped drives before the network stack has fully initialized and the computer has connected to the local network.

#5

Much appreciate Bennor.

Appears I drifted into Win 10 when released quite unaware of the issues with WD Cloud. Never had a problem with the shift to Win 10 (whenever that was feels yonks ago now ) at least not until I’d had this rebuild. Rattled through those steps anyway as some useful tweaks.

My Cloud is only set as visible in the home network with just one user and one private share. I have ‘cloud access’ off as I don’t have dire need to access it remotely. Thus no password to access that share. Have enough of them in life and others in house are women whose IT ability stretches to basic management of SKY+ handset.

I do use goodsync to map various backups across various devices. Its occasionally griped at a changed IP for the my cloud (not recently) and was tempted at setting static. But a peer into my routers home page left me as informed as if it had been in mandarin. So I will skip that in fear of bodging a mild pain into a crisis.

Can’t help feel its relevant to issue that only once I’ve opened smartware and giving it that 1 sec (without me having to click anything) to lose the red cross over my device on home page that then allows me to map a shortcut. Almost as if Smartware is kindly unlocking the device to windows for use!

#6

Rather than setting it static, you could set an infinite lease/timeout DHCP IP address. Sometimes has a user-friendly ‘always use this address’ control. Often found at a network devices listing page in the router’s UI.

#7

did u try use ipaddress to map