Lost Access to Shares after Twonky Update


I recently lost access to all of my shares after a recent Twonky update. I am very unfamiliar with Twonky and been unable to repair my share access. Can someone assist me with this issue? How can I revert back to the original WD management interface?

Twonky update?


Where from?

What My Cloud model do you have?
How did you “update” Twonky?

One typically cannot “update” Twonky without doing a full firmware update/upgrade. If you did a firmware upgrade/update, what firmware version did you update too?

If you performed an “apt-get” via SSH in an effort to update either Twonky or the My Cloud chances are high you will cause problems with the existing My Cloud firmware due to the way WD has programmed the firmware.

This is exactly the problem I have but don’t confuse things by describing it as a Twonky Update, even is actually the case.

I have a WD My Cloud NAS (P/N WD8CTL0020HWT-00) which has been running perfectly well backing up the files on 2 laptops on my home network, both running Win7. Using Windows Explorer all folders (Shares) were visible and accessible on this NAS on both laptops.

On Thursday last week a WD MyCloud update appeared on my screen (after a restart) offering bug fixes. Bug fixes my giddy aunt!! This caused a complete change in the way the NAS was to operate requiring me to sign up to a WD2go.com service to provide access to my NAS “from all my mobile devices”. NOT A CHANCE I don’t use or want access from any other devices, I just want to back up my files and when I try to connect to the NAS using either Windows Explorer or WDSmartware (which I had used for my backup system - ACCESS IS DENIGHED!!
The NAS is now invisible to my laptop. But wait a minute, all files and folders are still visible to the other laptop which has NOT had this update installed.
WD Support so far has offered no solution other than Factory Restore of the NAS which has been ineffective.
Some investigation brought up this:
SMB Permission problem with new firmware update

however, if there is a fault in an updated firmware file installed on the NAS, why does it not affect both laptops??
My laptop is still affected despite I have done the following:

  • run a windows System Restore to a condition prior to the update,
  • removed all WD software
  • reinstalled earlier version software
  • run System Factory Restore on the NAS

Can anybody advise a fix for this please? Any help much appreciated.

PS I cannot advise the update version. The NAS firmware version now is v04.04.03-113
The earlier laptop software was version

Thanks, Jerry

On the computer that has access problems have you tried accessing the credentials manager in Windows and remove any entries for the My Cloud, reboot and try to access the My Cloud again.

If other computers work with the My Cloud post upgrade but one doesn’t that would tend to indicate something is different with that one PC that is preventing access.

Bennor, thanks for your response.

Yes I am sure it is something is different now on my computer. I looked at my credentials manager under User Accounts and find there are no Windows Credentials or others in the Windows default vault.

Any other ideas?


You may want to compare the network and firewall settings between the PC that works and the one that doesn’t to see if something is different on the PC that is having trouble. I would also ensure NetBIOS over TCP/IP is enabled on the troublesome PC along with having the Network set to Private.

Thanks again Bennor. These settings are as you suggest. I have also compared “Turn Windows Features on or off” on both laptops and there is no difference.

One difference I have found is in Device Manager where Western Digital NAS is listed as a device (with no drivers) installed on my troubled PC. There is no such device listed on the functioning one, which connects to the router wirelessly.

I am thinking that my only solution is going to be to do a Factory restore of my Windows 7 pro :sob:

[quote=“Jerry_Lunt, post:8, topic:167651, full:true”]
One difference I have found is in Device Manager where Western Digital NAS is listed as a device (with no drivers) installed on my troubled PC. There is no such device listed on the functioning one, which connects to the router wirelessly.[/quote]
What happens if you remove the My Cloud entry in the Device Manager and reboot the computer?

If one can still access the My Cloud on the one PC that is having trouble by using the My Cloud IP address (or My Cloud name) in the Windows File Explorer address bar, or can “map” a Share so it shows up as a connected drive in Windows File Explorer, there would be no need to do a factory restore just to fix this one issue with that computer’s Windows File Explorer not showing the My Cloud under Computer in Windows File Explorer.

Prior to reading your post, I reinstalled WDMyCloud.exe and WDSmartWare.exe on the problem PC. Both can access the NAS. WDMC displays all the folders and files - but that is all I seem to be able to do there.
WDSW hooks into the NAS and when I click on the NAS icon to set up a backup routine, it requires me to input credentials - username and password - I have neither.

I deleted the drivers in Device Manager and rebooted. Immediately in the lower right side a popup says new device drivers found, so I click on that and a box opens showing it is searching Windows Update for drivers. After some time this box declares them installed. I go back to Device Manager and sure enough Western Digital NAS shows up again with 2 branches for My Cloud Network Media Server and My Cloud Network Storage. However, if I right click and open Properties, it tells me “No drivers are installed for this device”. There again, if I click on the Driver Tab it lists a driver and details its dll location. :confounded:
Typing “//wdmycloud” into the address bar of Windows Explorer brings up the NAS Dashboard in Internet Explorer.
Trying to map any share on the NAS drive does not work because it is not found.

The NAS does not show under Network. On the right side it shows as a Storage device but a right click and OPEN produces NADA/NOTHING.

I’m stumped. :unamused:

To access the My Cloud by name or IP Address in the Windows File Explorer or when mapping the drive one uses "\\" not "//". For example:

Note: Because of the way this site’s posting system works it causes problems when attempting to post certain code, in the example posted above there is no space between the "\\" and the IP address.

Thanks for that.
In the notification area, (screen bottom right) there is the WD Quick View icon which gives access to a mapping routine for the NAS shares:

Clicking the Finish button brings a box saying “attempting to connect to… (the share)” which just sits there until I’m fed up and I close it and the Map Network Drive box then this is hidden below:

So the NAS is completely hidden from normal Windows actions :confounded:

Have I messed up some Windows update routine? (or some Router setting - unlikely)

Try mapping the drive manually through Windows File Explorer using the My Cloud IP Address to see if that works. General direction for the manual mapping method in Windows 10, 8.x, 7 & Vista can be found at the following link:


‘Connect using different credentials’, those being your mycloud username and password. You must unmap all MyCloud shares first; a Windows issue with mixed network credentials.

Sorry, not enough information for me.
Connect using what?
How do I unmap shares that I cannot see.

We seem to be missing the point. It is either a problem caused by the NAS or something has gone array with my Windows system.

There are 2 laptops on my home network. Jerry-LT2 has had WDMyCloud.exe update version installed which seemed to have created the problem. This was removed by using a Windows Restore Point prior to the installation then v1.0.6.13 was re-installed but the problem remained. This was removed and reinstalled again. The NAS Dashboard is always available by entering its IP address into the address bar of Internet Explorer OR Windows Explorer but the drive is not shown under Network in Windows explorer:

The second laptop, Hilary-LT has not been messed with and this can still access the NAS using Windows Explorer - all shares, folders and files are accessible:

So, it is not possible for me to map the NAS from Jerry-LT2 because it will not find it, despite being able to show its presence under “Storage (1)” on rhs of the window. Right clicking on this opens options including “Open” but clicking on it does nothing.

The firmware on the NAS seems to be the latest 04.04.03-113 installed about 26 May - long before the problem arose.

As asked above, have you tried to manually map the My Cloud using an IP Address?

If you can access the My Cloud’s Dashboard using an IP Address you can typically access the My Cloud Shares using an IP Address. For example to map the Public Shared Videos subfolder via an IP Address one would use something like the following: \\\Public\Shared Videos

Note: Substitute your My Cloud IP Address for used in the example.

Does not work. I put some pictures into the \Public\Shared Pictures via Hilary-LT but trying to map it using the address \ \\Public\Shared Pictures produces the “Could not Find…” dialogue box and clicking on Diagnose, Windows says it cannot identify the problem.

Is the problematic computer in the same workgroup (typically “workgroup”) as the other computers and the My Cloud? Is the problematic computer in the same IP Address range pool (192.168.1.x) as the other computers? Have you tried turning off the troublesome computer’s firewall (or security software)?

Note: I assume you didn’t have spaces between the slashes and the slashes/IP Address.

The fact that other computers have no problems accessing the My Cloud indicates its NOT a My Cloud problem, probably not even a network problem (like with the router/gateway) rather it is a problem with that one computer.



YES - Both[quote=“Bennor, post:18, topic:167651”]
Note: I assume you didn’t have spaces between the slashes and the slashes/IP Address.

Correct[quote=“Bennor, post:18, topic:167651”]
probably not even a network problem (like with the router/gateway) rather it is a problem with that one computer.

So my only recourse with any degree of certainty would seem to be to reinstall Win 7 - ugh, a long task.

FINALLY, maybe, please assure me I’m not being completely stupid in that I have not run the procedure of setting up a MyCloud.com account and this is the reason my laptop cannot see the NAS.
I find it hard to believe this would be the case for this reason:
I had an additional Windows Backup schedule running (target being the NAS) which since this problem arose, now reports backup has failed because “the network location cannot be reached”

No nothing on the My Cloud should be preventing that one PC from seeing the My Cloud primarily because the OTHER computers can access the My Cloud.

One other suggestion since reinstalling Windows 7 will end up being a big time expense, go to Uninstalling a Program under the Control Panel and view the list of installed programs by date. See what programs have been installed recently to see if anything there seems out of the ordinary and which may be the cause.

It just feels like something is wrong with the network or user settings on that one PC.

Probably couldn’t hurt to see this Microsoft support link: http://windows.microsoft.com/en-us/windows7/why-can-t-i-see-other-computers-on-my-network

Double check that the Network Location is set to Home. Setting it to Work or Public may cause problems with accessing or seeing other devices on the local network.