Lost 2 TB iSCSI target

Hello everyone,

I just lost a 2 TB iSCSI target which had around 1 TB of data inside. I have now recovered it and wanted to share my experience so you won’t waste your time if this ever happens to you.

So my iSCSI target’s alias was “recovery” and its iSCSI Qualified Name (IQN) was “iqn.2013-03.com.wdc:wdmycloudex2100:recovery”. It had no security (choosed “None” instead of “CHAP” on the “Security” page at creation) and was sized at 2 TB.

I don’t know how the EX2100 lost it nor when, I just suddenly found out that it was not listed under “iSCSI Target List” (Dashboard > Storage > iSCSI). Upon checking from Windows, it was not listed under “Disk Management” as well, so something was wrong…

I created another iSCSI target named “test” with no security and with a size of 1 GB, then clicked on “Details” to find more about its image file; which was showing exactly as “Volume_1/.systemfile/iscsi_images/test.img”.

I connected to the EX2100 through SSH to see if there was also an image file for my previously created (and now lost) iSCSI target which had the alias “recovery”. I used the command below to search for it. You can also see that it was found in “/mnt/HD/HD_a2/.systemfile/iscsi_images/”;

root@WDMyCloudEX2100 root # find / -name ‘recovery.img’
root@WDMyCloudEX2100 root #

I used the command below to see its size;

root@WDMyCloudEX2100 root # ls -l /mnt/HD/HD_a2/.systemfile/iscsi_images/
-rw-rw-rw- 1 root root 2000000000000 Oct 21 04:29 recovery.img
-rw-rw-rw- 1 root root 999998440 Oct 26 02:00 test.img
root@WDMyCloudEX2100 root #

You can see that the size (2000000000000) was matching for my 2 TB iSCSI target, which looked hopeful at this point.

So what I did at this point was to create a new iSCSI target with the same alias (“recovery”) and hope that it would somehow register it with the already existing iSCSI target without over-writing it… Since I was using RAID 1 with 2 x 4 TB hard drives, I wouldn’t be able to set the new one’s size at 2 TB as well (received an error saying that the target size was too large as I didn’t have that much space left), so I just set it to lowest possible, 1 GB instead, and clicked on “Apply”!

Voila! Guess what? My iSCSI target re-appeared back on the “iSCSI Target List” with a size of 2 TB! Next step was to try and connect to it through Windows to see if data was intact, which indeed was!

So in summary, if you lost an iSCSI target, you might be able to recover it by creating another one with the same alias - and seems like size doesn’t matter at all. However, I would always suggest you to contact WD’s technical support before trying this on your own, if your data is important. This action plan I shared resolved my problem but it might not on your case; you might even corrupt your critical data if you’re unlucky!

Finally, I don’t know what caused this issue to begin with, but it made me a little bit nervous and now I’ll have to think twice before using an iSCSI target to store important data. Who knows if I’ll be this lucky the next time!?



Hi, thank you very much for sharing this information, hopefully will be useful to any user that might be having the same issue.

1 Like

This is my exact problem too. Can’t thank you enough for posting!!

1 Like

Me pasa igual un volumen iscsi que no carga después de un reinicio.

La solución winscp copiar el .img a tu pc y luego intentar abrirlo con 7zip…

Just registered an account to thank the OP for the solution. While this is indeed documented on https://support-en.wd.com/app/answers/detail/a_id/14166 as requiring that the image size be equal or greater than the original one, it did work with 1GB.

I have 12TB of disk space and a 11TB image file. I obviously did not have enough disk space to recreate a 11TB image.

1 Like

I had 3x 4TB running RAID5 with a total capacity of 8TB, I made 6TB iSCSI Target, which somehow got lost and I wasn’t able to connect anymore, Later I found out that the .img file exists but the target has gone missing, I contacted WD they told me that I need to put in 6TB in Size field while creating a new target with the same name, I only had 1.86TB remaining in my RAID Array. After 1 week of going back and forth WD support I decided to somehow solve it myself, That’s when I found out about this forum post, I was afraid initially to create a new target with same name but with 1GB in size because I thought it would overwrite my 6TB image, I tried to copy the image file via SCP & Rsync but it was only giving 10MBPS (my fault, I didn’t notice my host mahine was using 10/100 Ethernet) transfer failed after 6 Days with 90% progress, I was fed up, I opened the panel, created a new iSCSI target with different name, made a copy of it’s image, deleted the target, made new target with the name of the copy but with lower size, I sucessfully verified that lower size doesn’t overright the existing image, deleted that test target & made new one with name of my orginal 6TB target and I put in 1GB as size. Voila it worked. I just registered to thank the guy who posted this. You’re amazing man. I successfully managed to recover all my files (after alot of my stupidity and delay from WD’s side).

Registering also just to say that this still works in 2021…

Amazing, I never imagined WD NAS systems would lose an ISCSI target…

Hint: If you forgot how you named your drive, and you used it on a windows machine, open start menu → ISCSI initiator, you will see the name here:

So in my case it was “default”

I had the same problem, it was very complicated to solve and my backup was not working for a few days… I ended up solving it with an official solution from the link below. What I would like to know is what I need to do so that it doesn’t happen again.


I registered here just to say thank you very much.

WD support I found useless.

Man, your help was very useful to me, before I test this i make a backup for .img but it’s worked 100%, thank you so much!! I’m using a EX2 Ultra.

To relate my experience;

I had a ISCSI volume of about 8TB with less than 1% free space available. My MYCloud device installed a firmware update that crashed my ISCSI volume since it require 1% free space. WD support was not very helpful in providing a path to recovery mostly just sending links to various useless articles. If I asked the right questions I could get some answers but then you have to know what questions to ask.

I could see the ISCSI target in the WD dashboard but could not connect to it. I also noticed that there was no alias or name.

I purchased two stand alone USB connected 12tb drives and used WinSCP to copy the image file and attempted to open it in various ways with no success. I asked about expanding the RAID volume with larger drive and got the answer that this could be done without affecting the integrity of the data. I purchased four 4tb drives and began the process which took less time than I thought. Once the process was complete I still could not connect to the ISCSI volume. I found this link and followed the instruction to create a 1tb iscsi target using the name of the image file and that resurrected my iscsi volume and I could connect to it but not I can’t mount it and disc manager somehow shows it as missing although it shows in discmanager. Attempting reactivation fails.

This is all because WD forced a potentially harmful firmware update without a check to see if the space requirement could be met.

I am open to suggestions.


I used the following diskpart commands which bought the volume online and now I am able to back up the files to a USB connected drive. I’ll then run chkdsk and then attempt to expand the the ISCSI volume.

  • list disk
  • select disk
  • Online disk