Losing network connection

My WDMC has worked perfectly until recently. I had an issue with Safepoints which is now resolved, but now I’m tearing my hair out again.

It is set to be always on, with no drive sleep activating. At 1am each day a Safepoint is written to an external USB drive. It has a static IP address on my network

The last four mornings I have tried to access my MC dashboard only to find that it’s inaccessible.

A port scan shows that only ports 22 and 2049 are there, whereas in the normal course of things it’s 21,22,80,111,139,143,445,548 and 2049. Therefore I’ve lost port 80 and that’s why I can’t access the dashboard.

The only way to get going again is to reboot via PuTTY, after which all is well. Prior to the reboot I’ve also rebooted my router, but that’s made no difference.

WD support’s only answer, after perusing my system logs is to do a full factory restore, which I am very reluctant to do - it could take 3 or 4 days before I have it fully operational again, if not even longer. Added to that I’m off on my hols next week and was hoping to be able to access my media on the MC whilst away, that ain’t going to happen now :cry:

Wd also asked what I was using port 111 for, I don’t actually know!

To aid further diagnosis, I’ve disabled the Safepoint schedule, so I’ll see what awaits me tomorrow morning. My next step after that will be to do a Systenm Only restore, unless anyone comes up with any other ideas?

I could of course schedule a reboot for crack of dawn each day, but it’s not ideal.

Is anyone able to be of more use to me than WD Support?

personal opinion that is bad advise from WD. the only value of a full factory restore is is you are getting rid of the mycloud as it writes multiple patterns to prevent data recovery, a quick is the same as full but just deletes data.

I would alway try the system only restore before either the quick or full factory as it leave the data ans shares in place

I wouls also stop the safepoint backup and remove the USB drive until everything else is stable for a few days

1 Like

About two three weeks ago i had created a thread where i provided a script. The script would be run via a cronjob,e.g every 30 mins. if it detects the network connnection is down, it first restarts the network services, it performs a network check again. If the issue is resolve, good, the script stops, if it determines the issue still exists, it reboots the drive.

Here’s that post. You can use it as a workaround if you want. I know its not a real fix but it helps.


1 Like

Thanks,sounds great, I’ll take a look tomorrow.

Well, after disabling the scheduled Safepoint, I found that my MC was wide awake this morning, just as I wanted.

I’ve enabled it again now, just to see if it really is Safepoint. See what tomorrow morning brings.

WD Support have now backtracked a little and advised a System only restore, also asking for netword details etc. I’ll follow all that up tomorrow.

Strangely though, the MC has felt a great deal more ‘solid’ for the past 24 hours, response, transfer speeds etc. but I can’t nail any particular reason. I just wonder if something else was going on that I was unaware of, I don’t like it when I don’t know.

Reenabled Safepoint, and all is hunky-dory today, everything working fine.

Perhaps I’ll never know what the problem was.

About to go on holiday, so leaving it for now, sun is the main priority now!