Lose confidence in WD

Hello everyone,
I want to tell one thing,
I am currently using WD My Cloud,
My (WD My Cloud) has a problem,
I restarted WD My Cloud, just started to connect, and then automatically broken,
Contact Eric today
(Technical Support L1
Western Digital Corporation),
Eric said the need to replace the new (free replacement)
But if you need to save WD My Cloud internal files,
To pay their own,
To find their own manufacturers,
To contact their own manufacturers,
Is this warranty a fake?
The quality of WD is very disappointed
WD company warranty is very disappointed
I have also asked Eric customer service it ???
Eric’s answer is NO
This company has no customer service unit !!!

我目前有使用WD My Cloud,
我的(WD My Cloud)出現問題,
我重新啟動WD My Cloud,剛開始能夠連接,之後會自動斷線,
(Technical Support L1
Western Digital Corporation),
但如果需要拯救WD My Cloud內部檔案,


No, the warranty is not a fake. It is the same as the warranties of all other hard disk manufacturers. No manufacturer warranty includes a data recovery service; they only provide for device replacement.

Data backup is the user’s responsibility. If you don’t have your data backed up, that is your fault, and you will have to pay for it yourself.

If you don’t believe me, go and search for HDD manufacturer warranties, and show me one that provides data recovery under a consumer warranty.

WD have many faults, but their warranty isn’t one of them.

Got you.
So, I have the same issue as well.
Now I know that I have to get Other Cloud now.
Thank you.
I thought WD made things easier…
I was fooled.

I’ll grant you that’s the poorest aspect of their warranty, especially if you have an early failure. I almost mentioned it, but it seemed a complication compared to the primary complaint of the warranty not covering data recovery.

@sj-zhan and @TonePhotography

On reflection, you may both have misunderstood the ‘Cloud’ bit of the MyCloud name, and have thought it provided the redundant data storage of a true Cloud Storage Service, with your data held in one or more huge cloud data warehouse facilities.

This is not the case; the data is only held on the MyCloud, unless you provide a backup store for it. Basically, it is a NAS, with some limited remote access. The basic, single-bay MyCloud has no built-in redundant data storage, but other members of the family provide RAID of various flavours.

MyCloud was working fine until the latest update.
Over 4 years, some problems but the machine handled itself and solved that issue.
Not this time!!
Did someone forget to write the USB port sharing program??!!

The USB port is not a ‘gadget mode’ port!! It cannot be hooked up to a computer! (It IS a computer!)

If you do not feel scared of the console, you can enable SSH access, and attach a suitable USB drive to the port, then initiate a local copy to the USB drive.

To do that, you will need to do the following.

  1. power on the mycloud.
  2. attach the USB storage to the port and wait a few seconds.
  3. connect to the mycloud over SSH.
  4. at the SSH console:


This will list all the current filesystems and where they are mounted, what free space is available, etc. You are looking for where the USB storage got mounted. Make note of it.

cp -R /mnt/HD/HDa_2/* /mnt/USB/[name of USB share reported by df]

This will begin the local copy.

If there is a physical defect on the internal HDD, and you cannot power on the mycloud to get to the ssh console, OR-- the file copy operation breaks because of bad file reads-- Ask WD Support if they will honor the warranty if you remove the drive from the NAS’s enclosure for data recovery purposes prior to sending the unit for replacement. If they say YES, open the MyCloud, remove the Sata drive, attach it to a computer’s SATA port, and use something like testdisk to recover the files. (testdisk is free, works on both linux and windows, and knows how to deal with EXT filesystems.)


I couldn’t get to the Dashboard at all. Not able to turn SSH on, of course.
The USB port on the MyCloud is connected to a MyBook, by the way.
It was all fine… like I mentioned; until the firmware update installed.

I will tare that apart once the Baffalo station arrives.

I can’t wait to pull that HDD out… can’t work without it.
It has been over a week waiting for it to get back online.

Hi @TonePhotography - Have you tried resetting your router, computer, and device since updating the firmware? I’ve come across cases where the device wasn’t recognized until this was done.

What color is the front LED? Blue or some other color? Can you access the My Cloud Dashboard via either http://wdmycloud or http://wdmycloud.local or via the My Cloud IP address? Have you tried rebooting the network router and the My Cloud unit? Have you tried connecting the My Cloud direct to a computer’s Ethernet networking port? Have you tried a 40 second reset? Has any network hardware been changed like a new broadband router? What other troubleshooting steps have you tried?


I have been working on this for a week. I did everything I could.
rebooting more than 20 times now… not getting it back yet

You appear to have spread your problem over at least three threads, so it’s hard for anyone to keep track of what you have, or have not done. And you haven’t really said much about what you’ve tried. So it’s understandable that people will start with the basic debugging steps first.

If all else fails, you could open the case up, pull out the hard drive, and connect it to a PC to retrieve the files. From your description, it sounds very much like your data is still there, only the OS has become corrupt during the upgrade.

Recovery can be done fairly easily:

Having recovered the data, search for the ‘debricking’ or ‘unbricking’ guides that can be found on the forum, and re-create the OS disk.

1 Like