Looking for advice/tips on data recovery

Hi There,

I have a Passport Essential external hd. Recently the password got corrupted and I can no longer access my data. My only hope is to reformat, then run a data recovery program. I’ve been locked out, so no files have been overwritten. I have a few questions before attempting this…

  1. What is the best data recovery program to run? Is the make/model of drive relevant when choosing the recovery program? I would prefer one that is free of course, but would be willing to pay some nominal fee, say up to ~$100.

  2. I have the choice of running from WIn7, XP or Mac. I’m guessing Win7 is best?

  3. Where do the recovered files end up? If it is on the computer’s hd, then that means my XP machine is no good for this. 

  4. If I run a data recovery program and get only partial recovery, can I try it again with a different program?

  5. Are there any options/settings that I should be aware of when reformatting which might lead to a better chance of recovery?

  6. Any other tips that I should be aware of?

Thanks in advance,

Wile E. Dingo

First DO NOT FORMAT now. You will most likely need another drive to copy the recovered data. This might help  http://www.easeus.com/data-recovery-software/  Recuva is free  http://www.piriform.com/recuva Look around some recovery software fixes corrupt drives. You can also try booting from a Linux Live CD and see if you can access your data.


1 Like

Thank you for your response.

I have Stellar Phoenix, which is supposed to be good.  When I run it with the problem drive connected, it can’t see the drive. The problem, I suspect, is because the file volume is password protected. Only the VCD which holds the WD Smartware software is visible. I think this is why all other posts I have read on the subject say that you have to reformat which will allow you to then gain access to the file volume. Then, it seems, I should be able to run a file recovery program to hopefully restore the files.

Just to be clear, I believe only the password has been corrupted. Apparently it is stored in the hardware, which is why it is impossible to crack bypass. But I’m no expert on this by any means.

I’ve never had to do this before, so am a little unsure as to how to proceed.

Does the drive show in Disk Management?


1 Like

Yes, it shows up with two entries:

First entry:

WD SmartWare (E: )

668 MB UDF

Healthy (Primary Partition

It sees this as a CD-ROM because (I think) it is set up as a VCD (Virtual CD)

Second entry:

Disk 1



Not initialized.

This is the main file storage location. It asked to initialize this volume, but I declined.

Typically when you plug the drive in, the VCD runs and when security is in place it asks you for the password. If it accepts the password, it then sets up Disk 1 as My Passport (G: ), and then you have access to the files.

Update: Stellar Phoenix doesn’t work well. It seems …um… foreign made.  I downloaded the trial version of Easeus and tried it out on a memory stick. I selected 1 file and it restored it. Very nice.  The trial version is only good for 1GB of files and I have much more than that to restore.

This case was elevated to WD Support level and I am expecting to hear from one of their technicians.  I will wait to pay for the full version of Easeus until I’ve heard from the tech.