Long h264 files do not play


#1

Since the WD TV Live does not play AVI DV files (as of yet) I have been re-coding AVIs to h264 but I find only shorter files (< 2 Gb) will play back correctly. Files longer than 2 Gb will not play. Has anyone encounter a similar problem?


#2

What program did you use to encode?

If you use Handbrake and the High Profile preset but change the output type to MKV it will work just fine.


#3

If you’re using Media Server instead of network shares, that can be a problem.   Some media servers do not support files greater than a certain size.


#4

Thanks for the replies. I use Sony Vegas to encode to h264 because I also edit the videos before encoding. I am storing the files on a WD passport drive that is formatted as NTFS but when I plug the drive into the Live Media player, only the shorter files will play.


#5

So, you say they’re h.264, but what container are they?   MKV?  MP4?  


#6

mp4


#7

Could be a whole lot of things, but it’s not due to a Live limitation (for example, the MP4 could be encoded improperly or not have “Large File SIze” enabled).

I do recommend you try with Handbrake to encode the AVI (just save the raw AVI out of your editing program, and then run it through Handbrake to encode it, but use the High Profile preset and change it to MKV for container type).  That will eliminate all encoding issues as the source of your problem.