Login password prompt - unable to access My Book Live despite resets (LED is yellow)


I’ve had a My Book Live connected to my my Windows 7 system for about 18 months now and it has worked fine. Yesterday, it appears to have lost connectivity - my files can no longer be accessed either through the Windows Shares or through Western Digital’s various tools. The drive does show up, but is now requiring login data. I do not know the username or password, and other forum posts talk about hitting the rest button with a paperclip in the back. This hasn’t worked. Additionally, the My Book Live’s LED upon being unplugged and plugged back in goes from blue to yellow and then apparently never reaches green. 

My main question: how can I reset the username and password? I don’t recall ever setting one up and so I’m wondering if this is some kind of error. It seems a function of Windows and not the My Book Live.

Any assistance would be invaluable!

  • Jason

Just an update to this:

The My Book Live came back on after a reset with a paperclip performed while the until was unplugged, then plugged back in. No password was required. Unfortunately, the drive only came back for a short time before malfunctioning again. Now the unit’s LED is showing a steady green light, but it is not being recoginized by my Windows 7 machine. 

Should I try connecting it via ethernet to another machine?


Have you tried connecting the drive directly to a router? If yes, are experiencing the same?

Please refer to the user manual page (10 ) to see how to properly attached the drive.


Yes ERMorel,

I did connect both via the router and directly into a laptop. Attempting anything I can to retrieve data from this drive. It has been exteremly unstable.

  • Jason