Live Streaming and Live Hub losing access to Windows shares over a wired network

I believe some aspects of what I am encountering have been reported by others, but wanted to describe my experience in full in the hope someone will know an answer.

I own a Live Streaming and a Live Hub, both on a wired network. Until very recently, they have both been served movie files using a Linux share from a QNAP NAS. I have built a new Windows 8 Pro box which I have copied my movie collection to, and would like to use instead of the QNAP NAS.

Both the WDTV devices can be set up to add the shared drive on the windows 8 box to the media library as a windows share. They scan to build the media library, media can be played, and all seems well. But both devices will intermittently lose contact with the Windows 8 box: they will either report that “the last content source has been removed” or “there is no media in the current folder”. This can occur (a) upon starting either device, or (b) after media playback has been stopped.

Perversely, when this error occurs, you can navigate via system-media library-network share manager and press enter on the network share to view the info on the added folder, and it reports the network share as “ready”. 

The error can be got circumvented once it occurs by restarting the WDTV device, or by re-entering the name of the workgroup (WORKGROUP) which restarts the network, or by telling the device to clear and rescan the library. Any one of  these methods does not always work, and it sometimes takes some trial and error before the connection to windows 8 box and the media library comes back.

Note that the sharing of these files from the Windows 8 box is working perfectly with all other devices on my network (including a non WD media streamer, several PCs, IPads, etc). 

I have tried lots of steps to try and stop this error occuring: stopped the Windows 8 box from sleeping or the drives from powering down, tried various configurations of user accounts and username/password on both the windows 8 box and on the WDTV devices, setting static IP addresses for the WDTV devices. None have worked to date.

For now I have moved back to streaming from the QNAP NAS via Linux. But I genuinely believe the latest version of the firmware has a serious bug in the windows networking implementation.

Any assistance with this much appreciated. 

Might be a windows 8 compatibility issue, do you have another PC that you could use to check if the same issue happens?

Just got my WD TV Live Streaming Media Player from I’m in California.

At the beginning, and even before getting it, I was very excited about it, but after only half a day of using it, I’m seriously  considering sending it back to Amazon and asking for a refund or buying a different brand.

  1. The first issue this player has is the fact that it does not communicate on a regular basis with my PC (Windows 7 Pro 64-bit) over “Windows Shares” or “Media Server”. I’ve already tried every possible network, shared documents and “WORKGROUP” configurations on my computer, including turning off the anti-virus and firewall, and nothing changes for better.

Basically, this WD TV Live SMP recognizes my PC maybe 1 out of 10 (I need to clarify that both my PC and the WD TV Live have plenty of Wifi signal… so, the Wifi Signal is not the problem).

  1. The same happens when trying to access Netflix. I takes a bunch of trials, before it finally connects with Netflix successfully.

  2. The unit has crashed or frozen several times (more than 5 in less than 12 hours) and consequently I’ve had to reboot it, which **bleep**, since the unit doesn’t have a power button or “force quit” command on the remote control, and this means that you have to physically unplug the AC adapter from the wall.

  3. It doesn’t read all video formats over the network, like .ISO images for example. For this you need to plug a hard drive directly to the WD TV Live via USB; yet Western Digital didn’t warn its customers about this on the product manual or any other marketing material. The manual only says the WD TV Live SMP can read .iso files, but it doesn’t tell you that only over USB port.

  4. .VOB files don’t play smoothly over Wifi. They stutter and freeze. They only play smoothly over USB.

This is all for now. I really hope that Western Digital does a more serious job next time, before releasing new technology and trying to beat its competitors. Maybe, hiring a better team of programmers who make a decent stable firmware will help.

I can assure you that the player does play .is files over the network using network share.