Live Hub Not Connecting To Internet or Network Anymore Via Ethernet

For about a year everything has been great with the live hub. I have explored every issue related to this problem in the WD community & have attempted all of them in some form or another. Here is my issue & what I am running 

WD Live Hub with Firmware 3.08.14 - (Yes I have tried legacy “rollback” firmware back to 3.04.17)

Motorola Surfboard SBG6580 eXtreme Wireless Cable Modem Gateway

Belkin Powerline Turbo Ethernet Powerline Adaptors - My live hub is cabled in via ethernet by powerline

(Other Computers In House running off of wireless from Motorola Surfboard - should not matter due to livehub being wired but…)

iMac Running Mountain Lion 10.8.2


HP Touchpad



Live Hub has not been able to connect via ethernet powerline. Powerline has been tested and working fine with a laptop via ethernet. Things I have tried


1.Automatic setup: Live Hub on automatic setup gets a very weird ip and the connection fails ( unable to connect error ) 

  1. Manual setup: plug in the ip manually - run connection test & the ip connects with green check mark & I get a dns error

  2. Tried google dns - no luck

  3. Tried firmware rollback to 3.04.17 - Should I go back further?

  4. 1 minute hard resets on WD - Router&Modem - Powerline Adaptors

  5. Red button paperclip reset on WD Live Hub

  6. Clearing network settings 

I really need help as this is out of warranty & customer service was no help - thanks guys happy Thanksgiving & You ROCK in advance…




Any preferred older firmware that I should roll back to? 

Can you connect to the internet if directly to the router or using another adapter?

Not sure what firmware to try, you might wanna try a couple of the previous releases to test

No same problem thru router directly via ethernet as well

Could it be settings on my motorola surfboard i am overlooking since i reset it? 

You can edit your posts, if you have more info.

But no, not really, if you are saying you can connect a Laptop to it ok, then the Hub should be the same, a Laptop will be assigned DNS and IP unless you have setup a static IP to it.

You should be able to look at the settings in your modem and find out what DNS settings it has, once you find them, add them and the IP as you did before, then there really should be no problem.

1 Like

Will go into router again and try that now… Thanks!


How did you go with this issue? Had my WDTV connected and working fine through ethernet last night, but today it wont recognize a connection at all… I missed the customer service line by half hour doh

Mine stopped working as well, same issue cant auto it and i get 3 red crosses when i set it manualy