Live book duo not working at all

Hi everyone,
Would be grateful for any ideas about what I can do to try and sort this.
My Live book duo worked okay since I bought it for two or three years but now it seems to be completely malfunctioning. I can’t see it as a network device, can’t log into the dashboard, can’t use WD cloud - if I try to access it from ipad app it says remote access has been disabled. The light on the front is constantly white never going to green. I’ve tried restarting it several times but no luck.
The hard drives seem to be going round as it is making a constant ticking noise.

For whatever reason you bricked it or it bricked itself. Go read some unbricking guides.

It’s impossible to answer your question without more information but the answer will probably still be the same: you bricked it and you will need to unbrick it.

The ticking noise is a VERY BAD indication. It’s possible you have a failed drive. Perhaps if you can tell which drive you can replace it and it might rebuild.

My advice is (1) DO NOT do anything else until you have figured out all your options and then decide.

(2) Remove one drive at a time (follow the instructions in the manual regarding removing HDDs) and start just long enough if one drive makes the noise but not the other.

If one drive makes the noise and the other doesn’t you might get away by replacing the ticking drive, then rebuild your RAID. I’ve found Amazon has the best prices.

Thanks for the advice ,I’ll take a look.