Lithum is seriously messing with iPad owners

Some new “Mis-behaviors” have appeared as of late when using this community via an iPad…

  1. When holding down the DELETE key in the Rich Text box, it goes very slowly.  Typically, the iPad will start slowly, and then accelerate deleting whole words at a time.  But no longer.

  2.  iPad spelling autocorrect goes NUTS now; replacing not just the word you might be typing, but combining multiple words together into utter nonsense.  

For example, if one types a word correctly, and then begins typing another word incorrectly, the iPad autocorrector will merge the previous correct word and the “corrected” next word into something totally different than the origin of both words.  I’ve only seen this behavior on Lithium based forums – Not just WD’s.  

Whatever Lithium is doing is to the RTE is dealing iOS devices very frustrating blows.

I know there was some comentary a while back that Lithium / WD was working on a Mobile solution – CAN’T WAIT to see it!!

I filed a support case with Lithium over this.

Hey Tony,

Concerning the spelling autocorrect, Lithium thinks it’s a caching issue.  They want to know if clearing the cache on your iPad resolves the issue.  They are not able to reproduce it.

Concerning the slow delete issue, they’re working on fixing it.  It is a bug.

Clearing the cache doesn’t improve it.

Can you give me all the information on your iPad - which model number and so on?  Maybe they’re using a different iPad to test on.  They’re saying that they can’t duplicate the issue.

Well well well.  They must have done something in the last four hours or so.

I can’t reproduce it now, either – but it was definitely doing it this morning!  :)

I guess in the end that’s all that really matters… :smiley:

I take it back.

Its still broken.

Heres a test to reproduce.

Try typing “Take it backa”

It will prompt that backa is wrong.  On my box, it actually suggests “Barack” as the replacement.  Do NOT accept it.  As soon as you’ve typed the final “a” hit backspace then space.  Since hitting delete to remove the incorrect a at the end corrects the word, the suggestion should disappear, but it does not.  Instead, if I then hit space,

For me, it yielded

“Take iBarack” obliterating the t of “it” and the space after it.


Moexamp seeds (after typIng “more examplees”)

I think the RTE is making it difficult for the iPad to distinguish word breaks.


I posted your reply for them to reproduce.  Now, they’re asking for a short video of the bad spell check happening.  I don’t know if you can even do that, but if you can and would, it might help.  Email it to me at

I wouldn’t even begin to know how to do that.

I tried using my Blackberry, but it doesn’t focus close enough to be legible.

That was my response.  I’ll let them know.

Bill, I tried clearing the AUTOCORRECT cache to see if that would fix it.  It didn’t… It made it worse.  It might be easier for them to reproduce it if they do the same thing.

Oh… And I just verified it does NOT happen at all in the HTML view of the editor…  So it’s only the RTE.

Geetgreat. <---- oops… There it is.

And here is another way to reproduce it.

Type ANY word incorrectly in order to cause the iPad to suggest a new spelling.  As soon as the suggestion appears, hit DELETE.  If the suggestion does not immediately disappear, that is part of the bug.  IOS removes the suggestion as soon as DELETE is pressed, presuming the typist is correcting it himself.

So now that the suggestion is on the screen, keep deleting until the WHOLE WORD is gone… The suggestion will remain.

Now hit SPACE.  The RTE will now DELETE the entire, previous, unrelated word in favor of the suggestion.

Wrong.  :)

I’m still passing your info along.  It appears that, right now, they’re just scratching their heads.

Lithium isn’t the solution, Lithium is the problem:

Haha… Franc, that’s awesome.  I wonder if that’s why they chose the name?

Until I became a frustrated Lithium [forum] user, I used to think that the “Powered by Lithium” slogan may have been inspired by Star Trek. The Enterprise may derive its “warp factor” propulsion from a dilithium crystal, but Lithium relegates my old clunker to impulse drive. Worse still, every time Lithium changes something, my machine needs to go into the shop for a refit, or I need to change my driving style, or I need to find another way to get to where I’m going. :slight_smile:

That’s funny.  Believe me, everytime we get an update from them, I’m scurrying to get bugs fixed.  I’m starting to agree with you about being frustrated.  I guess if I was just a lithium user I wouldn’t feel so manic anymore.  But being a lithium [forum] user, yeah, well that’s painful still at times.  :smileyvery-happy:

Bill, just FYI…  I just got a brand new iPad 3rd Gen today…  Problem still exists.

Good to know.  The last bit of info you gave seemed to give them some direction.  And the last they spoke with me, they were working on it.