Linux support for WD Black NVME 2018


#1

This new model 500GB (WDS500G2X0C) doesn’t work, it keeps freezing any live image like Ubuntu 18.04 or Fedora 28 before install.

This support page says: https://support.wdc.com/product.aspx?ID=1804&lang=en

Similarly, new versions of Ubuntu and other flavors of Linux support PCIe NVMe SSDs using the newer storage drivers.

What’s wrong?

I’ve enabled UEFI boot, and running the latest firmware on my bios. I can run a Lubuntu 18.04 live image. The SSD is shown under /dev/nvme0 but the nvme tool is freezing the system and sudo blkid doesn’t show the nvme disk ID. Same for gparted.


#2

I am confirming this issue on a brand new system for Fedora 28. For more details see this thread at the fedora forum and this bug report in Red Hat Bugzilla.

@Linuxian: Do I understand you correctly that Lubuntu 18.04 live image boots fine? Did you find a work around for Fedora?

Unfortunately, I did not find a way to ensure that I’m running the latest BIOS version, I have an open request at the manufacturer/vendor of my laptop for more information regarding BIOS updates.

edit: I tested myself with Lubuntu. Lubuntu boots (contrary to Fedora) into the live operating system, however, when I try to install Lubunt to the disk, the system freezes. The system hangs also under Lubuntu when I start gparted when it is scanning for the disks.


#3

See also: Ask Ubuntu.


#4

Nope, also installing Lubuntu is unsuccessful. IMHO any program that accesses the NVMe drive is freezing the system. BIOS and firmware were up to date, probably the new WD controller.

Trying to swap it for a Samsung EVO 970, at least that is working under Linux.


#5

Thanks for the reply. Today I updated my BIOS/EC to the latest available versions, but the WD Black still does not work. Interestingly, I had exactly the same Samsung SSD in mind you are suggesting to replace the WD Black.


#6

I replaced the WD Black SSD with a:
500GB Samsung 970 EVO NVME PCI-e 3.0 x4, M.2
This SSD is recognized correctly and Fedora 28 is running fine on it now.


#7

I am confirming this issue with WDS500G2X0C (got it with Sager NP8954).
Xubuntu 18.4.1 live boots up and recognizes the partitions on NVMe, but any attempt to read the device causes system to freeze completely. That includes an attempt to start gparted or fdisk.
Filed a ticket with WD support but there is no word from them as of now.


#8

Update: I just got a response from WD tech support.
The level of incompetence and ignorance on WD side is astonishing. Here is their answer:
“We regret to inform you that we have not tested our drives with Linux drivers.”
According to wikipedia WD has over 65000 employees.
I am speechless. Time to short WDC stock.


#9

Hi everyone in this thread,

I bought a WDS250G2X0C last week, and I also tried to install Ubuntu 18.04.1 and 16.04.5 on this NVMe SSD.

Firstly I went into same circumstance like you, Ubuntu cannot detect this SSD while installation.

And I found solution how to fix it.

  1. In the GRUB boot menu, press e to edit startup parameter
    Add nvme_core.default_ps_max_latency_us=5500 by the end of quiet splash
    Ctrl-x to boot up, the installer should detect this disk in partition step.
  2. After finishing finish installation, press shift while power on to enter GRUB again, add same kernel parameter nvme_core.default_ps_max_latency_us=5500, Ctrl-x to boot up.
  3. You will see Ubuntu boot up successfully, edit /etc/default/grub, add parameter nvme_core.default_ps_max_latency_us=5500 again, execute sudo update-grub. so that every time boot up will contain this parameter in the grub automatically, no more manually edit.

Wish this solution can help you to install Ubuntu successfully and have fun.


#10

Please take a look on my reply Linux support for WD Black NVME 2018
I think it might be helpful for you to fix this issue.


#11

thank you so much for posting this. I just about completed an order for two of the 1TB NVMe’s through amazon tonight when I saw someone saying they are having problems with Ubuntu 18.04. Had planned on one for windows 10 and one for Ubuntu 18.04 but after reading WD could care less about Linux I’m out, guess I’ll by the 970’s.


#12

I just ordered this drive to replace my existing Ubuntu drive. I appreciate the suggestion to disable low power mode with the latency parameter. I assume there isn’t any negative implications for this fix for desktop use? I’m also curious whether anyone has tried installing the 18.10 beta release to see if the newer kernel has fixed the problem. Although I’d prefer to run the LTS, I’d probably just install 18.10 if a newer kernel resolves the problem. Thanks!