Linux problem


First post here…

I know that WD does not formally support the Linux OS, but please bear with me and read on!

I have a My Passport Ultra 1TB drive, and this works as expected in Windows 8.1 on my Lenovo G505s laptop.  When I “Restart” the laptop and boot into Ubuntu Linux 14.10 the drive shows up in the file manager, I can read or write to it and I can “Safely remove” it and plug it in again at will - just what I wanted, I thought.

Now it gets interesting.  If I power down the laptop, unplug the My Passport and reboot into Ubuntu, when I plug the drive back it, the light flashes a few times then the drive starts beeping; it does not apper in tthe file manager but if I list the usb devices atached to the laptop (with the lsusb command) it appears.

I also have a desktop PC running several linux Distributions, and the My Passport drive is correctly mounted by them.

Any thoughts on what is going on?

Thanks in advance.


Welcome to the Community.

I would presume a power distribution issue since your drive’s behavior is different when used on other computers. Have you tried with a USB 2.0 cable?


But on the laptop, it works every time in W8.1, every time in Linux after a restart, but never in Linux if I boot straight in to that…

On the desktop, it just works

FWIW I use USB3 on the laptop, USB2 on the desktop.


Might have sorted this…

Thinking about it, one difference between my laptop and desktop PCs, the desktop only hs usb2 ports whie the laptop has both usb2 and usb3.  I had been using the usb3 port on the laptop, so I tried a usb2 port - it works fine!  No idea why, maybe a bug in Ubuntu?

Anyway, probably solved.

Well Linux isn’t one of the listed OS and these drives may or may not work on Linux.