Linux drive firmware update [moot]

Searching my drive model number ‘wdc wd30efrx-68euzn0’ and ‘firmware’ leads me to this page. https://support.wdc.com/downloads.aspx?p=201&#firmware

There are instructions for updating firmware from Linux but the download link downloads a Windows .EXE. I have searched for but not found the download link for the Linux firmware update program. Can someone help with this?

Thanks!

Edit: I tried substituting the name for the linux binary in the download link for the Windows program and found something. (http://downloads.wdc.com/sata/wd5741x64). I made it executable, verified it needed no shared libraries and tried to run it but it terminated in a segmentation fault.

root@yggdrasil:/home/hbarta/Downloads# file wd5741x64
wd5741x64: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, stripped
root@yggdrasil:/home/hbarta/Downloads# ldd wd5741x64
	statically linked
root@yggdrasil:/home/hbarta/Downloads# chmod +x wd5741x64
root@yggdrasil:/home/hbarta/Downloads# ./wd5741x64
Segmentation fault
root@yggdrasil:/home/hbarta/Downloads#

Edit.2: I’m running Debian Stretch (64 bit)

Edit 3: What about a firmware updater that works with Windows 10? I tried downloading the one from (LINK DELETED BECAUSE I CAN’T LINK TO TOO MANY WD SITES. :angry: ) The page does not indicate support for Win10 but I tried it anyway. With the drive connected via USB the Windows drive manager saw it but the WD updater did not. :frowning:

Is there some other way to update the firmware? It would be very cool if I could simply copy the firmware to the drive and it would perform the update itself. (I suspect that’s how the updater works anyway, ut perhaps accesses regions on the drive not ordinarily accessible to a user.)

Edit 4: I found the correct windows binary at the first link I listed. It worked and told me that there was no update for my drive.