Link to Download Transmission?

Hi @WIWIWWII, thanks for the additional details!

First of all I would recommend removing the screenshot. I do not understand why they are copyrighting a simple redirect html page, but they did, so I would refrain from sharing their code… :frowning:

From your screenshot I do not see the address you are trying to reach. Did you try to access the yourLocalNasIP/Transmission? If that is the case, I would instead try to bypass the first redirect and go directly to the remotewd address. You can always find it here even when not logged in: yourLocalNasIP/nas/v1/locale.

Can you try the following?

  1. Go to yourLocalNasIP/nas/v1/locale
  2. click on the address specified at the redirect_url field (in FireFox) or copy paste it to the address bar (in Chrome)
  3. log in if not already done
  4. visit the redirect_url_address/Transmission page

If with incognito mode you manage to enter (as @andokai did), it might be a cookie, session (unlikely), or privacy settings issue. Have you tried a different browser?

Hope this helps… :crossed_fingers:

Just because they say something it doesn’t mean it’s right. If there was a security vulnerability exposed by the Transmission web console that could be exploited to gain access to the NAS then I’d understand them needing to do something but they haven’t said that’s the case.

The last iteration of the Transmission console was password protected remember and while I guess the less technically inclined might not change the default login those of us that know better had it locked down.

Finally, while I do appreciate their attempt to move everything over to HTTPS the approach is poor. Rather than https://home.myurl.com I’ve got a GUID for a domain. Why not just put certbot on the box and let us pick our own domains?

Also, sorry @ggirelli I don’t mean to direct my rant at you. :slightly_smiling_face:

1 Like

@andokai, I completely agree with what you wrote. What I meant is that I understand where their decisions are coming from, but I do not think they are ‘right’ (or super duper well executed) in the least… Didn’t take anything personally, no worries :wink: peace and love :heart:

@ggirelli Thanks again! I learned a lot from this post! And found a solution (my PR4100), omg!

Btw, I never heard of yourLocalNasIP/nas/v1/locale. How do know all this? Where is the documentation for this info? I Googled for hours the last few days and never heard anything about a redirect_url. Are you a WD licensed psychic?

What I was doing in the first place

  1. I am logged in locally (not live at os5.mycloud.com, although, not that I was aware of)
  2. When following redirect_url_address/Transmission Firefox is trying to do something but eventually times out and displays a “can’t connect to server at …” message.
  3. I tried yourLocalNasIP/Transmission, yourLocalNasIP/Transmission/index.html and yourLocalNasIP/apps/transmission/web/transmission.html didn’t work out of the box.

What worked for me: (Tested working with Chrome & Firefox, not Safari)

  1. Log out of your local NAS and log out live at os5.mycloud.com
  2. Close all browser tabs and browsers. We need to create a new clean browser session.
  3. Open new browser window (Firefox or Chrome).
  4. Log in to your local NAS & live at os5.mycloud.com
  5. Go to yourLocalNasIP/Transmission/index.html
  6. After some seconds (super weird) I get redirected to yourLocalNasIP/apps/transmission/web/transmission.html and it is working.

Note: If i log in locally or live with another browser, the transmission session gets ended.

What I think is happening:

  1. First of all, the redirecting is just ■■■■ and childish. This jQuery-<body onload="go();"> -thingy is just asking to have cross browser compatibility problems. I think WD forgot to hire a front-end developer.
  2. I suspect the <body onload="go();"> is also causing problems where some users can only see Transmission in private / incognito mode. The body doesn’t get loaded again.

You know, I always think about this middle aged dude that just bought a brand new NAS for €500+ . Thinking he could do some stuff. Turnes out, you need to have expert level knowledge of all kind of things to get ■■■■ to work like a real NAS. How does a regular customer get to know these kind of things? Is WD cashing in on customer support calls? I bet they are redirected fine XD. Anybody wanne buy my PR4100 for cheap?

1 Like

Super glad you found a way! :smiley:

:sweat_smile: I’d love to be. I’ve just been digging into their build of Transmission for the past few days. I am trying to disable this horrendous redirect stuff and open it up on my local network! If I manage to find a working tweak I will share it here in the forum :wink:

I think there might be some issues in how they handle their dashboard open session. If I try to log in from another device it asks me to log out first from the other open session. While if I log in through another incognito window or a different browser it weirdly goes through. I guess they lock us out only from different IPs, which might mess up the PHP session details if you log into another browser/window.

I could not agree more. :pray:

Any way to hack this go(); function
I try edit file using vi and remove it but not works.
Other issue is Transmission stop to seed even configured to not stopScreenshot_1

this worked for me

Use ssh to enter the NAS
first, stop Transmission service (use WD dashboard. This is very important, because if the service is working, the changes made in the settings.json file will be lost.)
Then edit settings.json

(In my case, /mnt/HD/HD_a2/Nas_Prog/Transmission/config/settings.json)

Change this in settings.json:

"rpc-authentication-required": true,
"rpc-bind-address": “0.0.0.0”,
"rpc-enabled": true,
"rpc-host-whitelist": “”,
"rpc-host-whitelist-enabled": true,
"rpc-password": “choose-password”,
"rpc-port": 9091,
"rpc-url": “/apps/transmission/”,
"rpc-username": “choose-username”,

Save the settings.json file

Start the Transmission service and use this url: http://NAS-IP:9091/apps/transmission/web/
Now it will ask you for the Username and Password that you wrote in settings.json

or only change this lines and it will not ask for any username / password

"rpc-authentication-required": false,
"rpc-bind-address": “0.0.0.0”,

Let me know if you have any questions or need any help.

1 Like