Link Speed tab contains only two options

My Cloud EX2Ultra link Speed tab contains only two options Auto and 100, it is missing 1000. It was there when I first set up my system last year. I am figuring an update must have changed it. I am connected to a gigabit switch and all other equipment is functioning properly at 1000. …Is there a way to reset? …and will it delete all of the data on my 2 (3TB) hard drives?

That’s strange… You can do a system only reset under Settings/Utilities/Restore to Default and that will not erase your data.

Thanks …that is what I was thinking …I’m not sure exactly when it happened but, I know the option was there when I set it up and now there are only the 2 options and upon reboot it says “connecting at 1%” (connects at 100) …guess I’ll have to try a “system reset”

Well sadly “system reset” did not work. Everything remained the same. It “did” say that “system restore completed successfully” …however it was still on current firmware … I’m assuming there is no way to restore “older” firmware?

Btw, have you tried with another Cat5e cable or checked the LED on your EX2 Ultra’s Ethernet port if it has a green light? See page 10 of the UM:

Contact the WD Support team directly if your HW has issue.

Yes, I have tried numerous cables and the rear led lights are (1) yellow and (1) blinking green .