LifeGuard Diagnostics: 0 GB and SMART status not available

I have tested my disk using LifeGuard Diagnostics and get the results in the attached image.

In windows the option in disk management to initialize disk is greyed out.

What do you think I should try before simply deleting everything on the disk through LifeGuard Diagnostics?

It seems like there is an issue with the connection between the hard drive and the PCB. Or the hard is dead. If possible you can try to dismantle and try to connect just the hard drive to your internal computer SATA port see if it work. On how to do that, you can search in the forum on how to remove the internal hard drive.

Thank you for the answer

I have tried two different cables though and I know one of them is working.
Do you think it’s still relevant to try what you described?

I tried now to erase everything on the drive through LifeGuard Diagnostics but even that failed

Last thing to do is dismantle the unit and connect the drive to your internal SATA see if that help.

Thank you @jebusx
I managed to open the box. Do I just simply boot from this drive or do I need to have two drives connected at once?

You need both hard drives. The 1st one is your OS “Windows” and the 2nd is your WD drive
Hopefully, when boot in to Windows, it can see and assign a drive letter for it. Best of luck

Thanks for the clarification.
Unfortunately, I don’t have the equipment for this. So combined with the assumed low chance of getting it to run smoothly again it might make the most sense to just throw the drive away.