Led is on but my 3TB My book essential is not been shown

I have just received my new My book 3TB essential but I am very dissapointed. I have connected the hard disk and when windows finished the instalation the disk is shown but I can read or write any data in it. I have tried downloading and intalling the WD SES driver (x64 for my windows 7 64) but after that I cann’t  even find the hard disk. I see the securite unplugged but there is not any volumn label in my computer with the disk. I have tried in others computers and the result is the same. The led of the hard disk is always on and in white, without any blinking. This has never happend with my other WD hard disk (WD Elements 3 TB USB 2.0 )

Could you help me, please?

any help here please?

Here is what I would try first:

Go to Control Panel and select Device Manager. When the Device manager loads in, go up to the Disk Drives and check them to see that they installed properly. If it’s there, go to Properties and then Drivers and see if it will let you Roll Back the driver.

Also check the USB controllers for yellow exclamtion marks (indicating a problem, like device driver.)

And once again I recommend Easeus.com/partition-manager/ and get their free version. At least you will know whether your system is seeing the hard drive or not.