Latest update broke TimeMachine (Again)

Time machine won’t work again. Any way to convert back to old firmware? any help! PLEASE!

Screen Shot 2020-12-19 at 11.01.48

I had it working with the share not being public. Now, even with making the share public, it won’t show up. That trick used to work in the past, but I rather not make that share public if I don’t have to.

1 Like

ok here is an update. I guess I temporarily fixed it? The share originally was an afp share before the update.

After the latest firmware update the share became an smb share:

However, have the share password protected, not public, it still doesn’t work:

Screen Shot 2020-12-19 at 11.18.38

However when I make it public, it finally does the backup.

So. It works again. but using this EX2 for office and home, I really need to figure out how to make this share not public. My TimeMachine backups are encrypted, that doesn’t mean someone is prevented from poking around in my files.

So does that mean I can now turn off AFP in the settings? Would SMB3 be faster?

I hope this helps someone until the next update. And please, WD, fix it, please?!

1 Like

It is a pain in the arse with WD an the fact, that they force us to use the Time Machine as public. I found a solution around it. When you use the Time Machine in public mode, your MacOS changes it by itself to AFP. I guess here we just have to hope, that WD one day will allow us to turn AFP off.

So far to use TM with a non public folder do the following steps:

  1. Make your Time Machine folder non-public and add access to your preferred user

  2. Go to Finder and click Go -> Connect to Server.

Here you simply connect your MyCloud via afp://IP-Adress. I recommend to use the IP Adress, which you should set to static in your router.

  1. Type in your credentials and choose your Time Machine Folder

4, Now you should be able to choose the Server in Time Machine Settings. Check with mouseover that you are choosing the correct one --> AFP! In the futureTime Machine will automatically connect to the server and look for the “disk”.

So far this is the only reliable solution i figured out.

1 Like

Did you set a limit size for TM backups?

Yes, I did.

Remove it. It should work. Hope they fix this soon.

See: TimeMachineBackup works intermittently - #22 by SBrown

With the afp connection it works without problems. But I still hope that one day, they will remove it or give at least the option to disable afp and use a user instead of guest. Otherwise I’m considering changing to synology. They are very more professional and user friendly with their NAS systems

I manage to keep it working with SMB as I wished but I had to give up on size limits so far. I hope they will fix it soon.

I have not tried my chance with a non guest user.