Latest OS5 update crashes with blue flashing light

I got an email to update. When I did the drive crashed and I got the blue flashing light. After many attempts to reset soft and hard I ended up rebuilding from the original image and loading version 2 binary. It then upgraded to OS5 and during the setup on OS5 when it attempted to log into the cloud it crashed again. Same blue flashing lights and it is no longer accessible on my home network.

Will try rebuilding again and this time I will bypass all web app and web based access and keep it local and see if it still crashes. Since the old version of OS5 was running before the first crash, I will start with that.

Hi @Amixon,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

I filled out a request page on a WD site for the problem, I assumed it was the correct Western Digital site. I have determined after multiple reloads and trying to take the process slow to test at each step, that the hard drive may be the issue. My last load I tried doing maintenance from the OS3 GUI before going any farther. I started getting drive errors. I had an issue with my old loads not being overwritten by the new builds as well. All of the old shares and users were showing but only the video dvr shares was readable. I never could get the admin password to reset to factory. I tried the 40 second reset, even wiped out all partitions and rebuilt the table before the last load. The original admin pass I setup 8 years ago was still the only thing that would work either on the GUI or thru SSH. I have a new drive on order and will try and rebuild it this weekend. Hopefully it will work again. Note: even though I am able to get the GUI load page to come up and log in with my password, it still cant log on. It says it is still booting. The blue light is flashing as before. I think it has always been a bad drive and the system is trying to boot thru and verify the integrity of the system.

UPDATE. 3-11-23
I got the system stable in OS3 long enough to look at the file partition and run diagnostics. The disk had failed. Don’t know if Smart Drive is supposed to be off but it was at this time. Probably would have told me the drive was bad.
Have now installed a new drive and rebuilt using the thumb drive method described by FOX. After setting the raid to JBOD the system disk area formatted and I now have my drive back.

It is possible that most of the people with flashing blue lights have bad disks as well. With OS 5 the system reports that Smart is enabled. Dont know why it was off, but that could have reported the failing disk long before the blue lights.

Since few weeks I’m having the blue light flashing, cannot see it on the network and completely inaccessible. I mady all kinds of reset and still now change. I’m now paralised and not sure how to go about this. I don’t need the data as I have a backup, but I want to have the WD MyCloud running back again. Please help

Just happened to me last week. After research here I found posts that outlined ways to use a boot rescue usb and attempt to build and repair the drive. After may rebuilds that eventually led to the blue lignt again, I removed the drive and mounted it on a Linux computer. Checking the drive I found the data partition was corrupted from disk failure.
I replaced the drive with a new one and used the rescue usb method to create new partitions and reload the safe mode GUI. From there it updated and is now back in service. Make sure to enable SMART to be warned of pending failures.