Latest My Cloud Mirror Firmware Pre Installed on Brand New My Cloud?

Following firmware update on MyCloud Mirror drive

Note, this image shows the “Storage” field/tab whereas the image on the MyCloud Single Bay Drive does not contain this.

Conclusion = I have a single bay drive running Firmware 2.10.310 :)smile:

Look on the bottom of the 3TB My Cloud drive, what is the part number (P/N)?

Edit to add. It is confusing as to how many My Cloud Mirrors and how many single bay My Cloud drives you have in addition to the one My Cloud you are indicating has the wrong firmware on it.

Perhaps if you disconnected ALL other My Cloud and My Cloud Mirror drives but the one with the suspect firmware one can be assured they are accessing that particular My Cloud drive and not inadvertently accessing one of the other drives.

I’ve just remembered the Japanese model, the ‘WD Cloud’ (MyCloud name is owned by someone else in Japan, I think).

This has a dashboard that looks like that (except it says ‘WD Cloud’, rather than ‘WD My Cloud’); in fact, when OS3 was announced, someone found the manual, and we all thought it was for OS3. See p18:

http://www.wdc.com/wdproducts/library/?id=487&type=25&cn=4779-705143

Wonder how it’s found its way to the UK… Or have WD quietly swapped to the WD Cloud’s firmware…?

Mods, @Bill_S : could we get some clarification, please?

Gen2. Not a penguin, but maybe it is a new generation, with a faster processor, hence the ability to host apps, etc…?

Looks exactly like the dashboard shown on page 18 in the manual.

As others have suggested, I’ll pull the model number off later and compare with my other single bay MyCloud drives.

Wonder if Currys UK have been buying product across ?? Packaging was all in English but in a narrower format to that usually sold in UK.

The other interesting thing I discovered last night was that when searching for my drives on the MyCloud iOS app the image for this new Single Drive was very slightly different to the image for my other two single drives suggesting the app recognised a difference ?

& no Chinstrap :wink:

Easier to clarify the number of drives I have with a photo.

The single drive on the far right is the unit running the Firmware version 2.10.310

Product number is different -

2 Older single bay drives = WD BCTL 0030HWT - 00

New single bay drive = WD BCTL 0030HWT - 01

Here is the new ‘slimmer’ product packaging which makes printed reference to supporting Windows 10 & Mac OSX Yosemite which didn’t appear on previous ‘cube shaped’ packaging.

Intersting. The product numbers being different. Wonder if some units that weren’t supposed to be released yet slipped out. Which manual were you looking at where the Dashboard looked like the one on “page 18”? There is no image of the Dashboard on page 18 in the English version of the My Cloud User Manual: http://www.wdc.com/wdproducts/library/UM/ENG/4779-705103.pdf

The first image that I can see of the Dashboard in the English User Manual is under Chapter 5, The Dashboard Home Page (page 31). And it is the current My Cloud Dashboard.

It would be interesting to see what Processor, RAM (type/capacity), Networking port information that unit has and compare that to the current iteration of the My Cloud hardware. Hopefully someone will open the enclosure and report (or take pics) on the hardware. If one uses SSH they can issue the following commands to find out certain general hardware information about the My Cloud’s.
Processor information: cat /proc/cpuinfo
RAM usage: cat /proc/meminfo
Hard drive information: hdparm -i /dev/sda1
Network port information: sudo ethtool eth0

Post updated and edited.

So, the acid test: can you install apps?

Like Plex, for instance…?

It’s odd that next generation product seems to be appearing in shops, but there’s been no press announcement from WD that Google can find. I wonder if they’re hoping to clear old stock first…?

[may consider a trip to my local PCWorld to see what they have in stock…]

One other possibility of ‘diagnosis’; can anyone remember if the system diagnostic report includes details of the processor…? d’oh! I can use the MyCloud remote access app to look at a report I’ve saved on my device… I’ve never looked in detail before; it’s quite interesting all the stuff that’s in there, and gives a good idea of how the device works… /etc/samba/overall_share looks interesting, for instance…

update.log mentions ‘mindspeed’ (kernel-mindspeed-sequoia), which is the processor; so, if the gen2 device is using a different processor, you might expect to see a different processor mentioned…

Followed the link in CPT_Paranoia post further up this conversation.

The Japanese “WD Cloud” manual I posted a link to. As I said, the only difference is the ‘My Cloud’ instead of ‘Cloud’, and the banner colour. As he noted, there’s no ‘storage’ icon in the banner of the new device, unlike the Mirror…

Have a look at the post titled ‘How to sync two MyCloud at different locations’ - this senior manager from WD technical marketing is also a little surprised

Sorry not proficient enough to start sending the drive these instructions…

Limited apps…

There is a Safepoint migration from Gen 1 devices but I don’t see the options for Plex etc.

Ah yes missed that link. It is worth noting that link CPT Paranoia posted has on the very last page of the English manual what appears to be a manual/document version/date information: 4779-705143-A00 May 2015. While the current public WD Document site English manual version lists: 4779-705103-A02 Oct 2015.

Hopefully someone from WD will be along to clear up this difference in My Cloud units. It will create more confusion if your new unit is a Gen 2 version of the My Cloud and if that version supports features the current (first Gen) versions do not, like apps and the like. If WD actually does bring that interface and apps to the current (first Gen) version of the My Cloud in some future firmware update, so much the better.

1 Like

Bennor, the link I posted is for the Japanese market model, called the ‘WD Cloud’. It’s called that because ‘My Cloud’ seems to be owned by someone else in Japan (AkiTiO):

http://www.akitio.com/mycloud-series

[quote=“Ricard_0, post:23, topic:145284, full:true”]
Have a look at the post titled ‘How to sync two MyCloud at different locations’ - this senior manager from WD technical marketing is also a little surprised[/quote]
Yeah saw that earlier. Had a chuckle.

The good news is that the User Manual with the alternate interface indicates on page 53 one can manually add apps. That may bode well for those who want to try and run Plex or other apps that are not officially supported on the entry level My Cloud devices.

Manually Adding an App
If you have an app you’d like to add that is not listed on the Add an App screen, use the
following steps to manually add that app to your WD Cloud device.
Note: WD recommends that you fully understand the nature of any app before you
install it on your device.

  1. On the Navigation bar, click Apps to display the Apps screen.
  2. Click the Add an App icon on the lower left side of the screen.
  3. Click the To install an app manually, click here link.
  4. Navigate to the app you’d like to install on your device.
  5. Select the app you’d like to install, then click Open.
    The selected app installs and is added to your device.

Sorry not proficient enough to start sending the drive these instructions

That’s a shame. SSH login to the Linux OS is quite straightforward, and those cat commands are completely benign, and just dump the file contents to the screen, allowing you to see what cpu and memory it thinks it has. The hdparm and ethtool commands need a bit more care.

ps. how can you have that many Clouds, and never have needed to use SSH to get them to work properly…? :wink:

Brilliant !! - Thanks Bennor - I’ll see if I can get the PLEX App running tonight. :smile:

For comparison sake here is a dump from the My Cloud unit I have. I didn’t dump the hard drive since the current hard drive in the enclosure didn’t come with it. Would be really nice if the “gen 2” units supported Wake-On-Lan. :slightly_smiling:

# cat /proc/cpuinfo
Processor       : ARMv7 Processor rev 1 (v7l)
processor       : 0
BogoMIPS        : 1299.25

processor       : 1
BogoMIPS        : 1292.69

Features        : swp half thumb fastmult vfp edsp neon vfpv3 tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x2
CPU part        : 0xc09
CPU revision    : 1

Hardware        : Comcerto 2000 EVM
Revision        : 0001
Serial          : 0000000000000000

# cat /proc/meminfo
MemTotal:         232320 kB
MemFree:           67520 kB
Buffers:            4480 kB
Cached:            36800 kB
SwapCached:        16256 kB
Active:            49280 kB
Inactive:          47808 kB
Active(anon):      23360 kB
Inactive(anon):    39232 kB
Active(file):      25920 kB
Inactive(file):     8576 kB
Unevictable:        7936 kB
Mlocked:            7936 kB
SwapTotal:        500672 kB
SwapFree:         388032 kB
Dirty:                 0 kB
Writeback:             0 kB
AnonPages:         54592 kB
Mapped:            21056 kB
Shmem:              4416 kB
Slab:              17280 kB
SReclaimable:       7360 kB
SUnreclaim:         9920 kB
KernelStack:       13504 kB
PageTables:        17984 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:      616832 kB
Committed_AS:     521728 kB
VmallocTotal:     516096 kB
VmallocUsed:       39552 kB
VmallocChunk:     458688 kB

# sudo ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: external
        Auto-negotiation: on
        Current message level: 0x00000036 (54)
                               probe link ifdown ifup
        Link detected: yes

Media Sever for Mum & Dad :slightly_smiling:
Media Server for Teenager
Media Server for Child

Use the DLNA settings to block certain drives to certain screens in bedrooms. There may have been a cheaper way to do this but it works well, was simple to set up is easy to maintain.
Gives them each their own storage space too so no arguments…

Re the SSH commands - I’ll speak to my 10 year old, she’ll probably know :wink:

My WD drives have always worked well but then I’ve never really pushed them to do anything particularly technical.

Thanks for the advice, enjoying the forum.

R