Latest Java 7 update (51) kills remote acces

I need this to be fixed ASAP. I have two of the 4TB drives. If this is not fixed I will have to return both of them. I would hate to give these a bad review on my YouTube channel.

In general: don’t lower the security level; leave it on High.

Add TWO exceptions by clicking on Edit Site list. The name can be found on the address bar.

Add 1 https://… the secure connection with the link to your WD drive;

Add 2 http://… not secure connection, and the same address.

The name will be in the form

After doing that the connection is restored.


Thanks KeesN,

That worked for me

Just wanted to update everyone that we are testing a fix for this issue and should be moving forward soon.



And could we have a fix without using java ?

I don’t have admin access to install it on my work desktop. So, no access at all to my cloud at work and it’s why I bought it !

I am dealing with the same issue,   I started a new thread before seing this one.  Sorry

Where do I look to make the changes KeeSN mentions in the above post?

Tried including the sites in the Java settings.

Login to site - okay.

Login to share/network drive - okay.

Now I get Java error:

… is included in the Exception Site List because the application refers to resources on multiple domains. The jar file at file:/C:/Programmer/Java/jre7/lib/applet/WMPNS.jar is on a different domain and is not also included on the Exception Site List.

Tried in Firefox 26 and IE 8.

(Firmware version: 03.03.02-165)

jc4g10 wrote - Re: Latest Java 7 update (51) kills remote acces

2 weeks ago

I had the same problem last week, and now when I try to remotely access my shares the page doesn’t even load any more!
I also find it absurd that the WD users and community are having to lower security settings in order to use a feature that was this products biggest selling point.
A very disappointing effort from WD - a solution needs to be found quickly otherwise I foresee WD losing a lot of support from this product.


I will say that this Java update has caused similar issues for other completely unrelated software and systems.  I work in the IT department at a college and with the latest Java update we have had multiple problems of exactly the same security nature with software the students and faculty must use. Nothing to do with WD at all.  Our work-around has been the same as has been proposed here; to lower the Java security setting to Medium and subsequently click through any initial security warnings.  We too have been struggling with a more formal solution but the security adjustment works well.  My point is I wouldn’t blame WD for this issue.  It’s a Java related problem which affects users and software well beyond WD applications.

The only solution is to completely remove the latest Java and reinstall the earlier version Java 45. Turn Java auto update off otherwise it will put Java 51 back in again.

I don’t see anything of those links you posted here. Can someone shed a light on this ? Where do I see these ? Then I can put them in the Java Edit list.

For those who want more help - and can’t wait for WD to solve the problem.

Go to Control Panel. If you’re using Category: click Programs; otherwise click Java directly. Under Programs you’ll see Java:


Click the Security tab: Java1.png and then Java2.png

Add three entries, all can be found in the adress bar of your browser. One secure https and two http lines. The first two are composed from the name of your drive, the last one is your internal address, commonly in the form

See the examplebelow:


Ignore the extra warning message when entering the http address.

Hopefully it works for you now.

My point is I wouldn’t blame WD for this issue.  It’s a Java related problem which affects users and software well beyond WD applications.

I’m sorry, did you read the message in the pop-up?

The certificate used to identify this application has expired.       Isn’t that clear enough?

Are you suprised when you can’t pass the customs with an expired passport?

Did you read the next line too?

This application will be blocked in a future Java security update… There isn’t a word French in this warning. But still suprised that after a Java update they actually do what they say they would do?

Does anyone perhaps know how many months/years WD had to prevend this problem?

My point is WD is to blame for this issue.

in addition to what is mentioned above on adding to the java site lists, following site needs to be added as well:

http:// – device

as this is where the certificate is residing. (note the :80 being added to the url).

(tip: you can copy-paste the url from your browser, if you are not sure what the devicename is, i.e. everything in front of

Furthermore, I also added all my 198.xxxx urls into the trsuted site list, just to be sure :slight_smile:

When doing so, you can access the WD drive again (even with java security set to medium!!)

It works!!!

But it wont allow others to access your drive from their computers will it. Only the ones you have done the alterations to.

A lot of us need it for others to access files on the nas not just us.

@ArieB: Port 80 is the default for HTTP traffic, as is 443 for HTTPS (secure). No need to add that, but you’re free to add what you want. And why are you using an IP-address in the range Why don’t you stick to the IANA reserved addresses? See

For all others: I assume you let your WD MyCloud permanently on. What’s otherwise the use of buying one and when you are away from home your data is unavailable because it’s offline? This means your MyCloud will always have the same IP-address. Even after a power failure, your DHCP server will almost always give it the same IP-address. Add this ONE address to the exclude list. Not the complete range…


I needed to add the port 80-url as it gave java errormessage earlier on that the certificate could not be verified since it was on the url ending with 80, rather than on the url as added to the list of urls.

As for the 198 address: that is what has been assigned by the MyCloud box. I have not changed this, nor am I planning to do so (as now finally all works well…)

Bye to all.  I returned my WD MyCloud to the shop and bought a WD My Passport Ultra.

All problems solved. Only not to forget to take it with me when I’m leaving home.

Mine is being reset to factory default as we speak and it will be returned tomorrow as “not fit for purpose” and “not as advertised”.

If the only way to remotely access it is by lowering my security settings & telling my clients to do so as well (as instructed by a WD member on here) then this item and WD in general is a joke.

Bye bye

The fact that they are even using Java in the browser is ridiculous. Find another solution.