Latest firmware messed up my Media Library


I have a Western Digital Live Streamer Gen3. Latest Firmware(from last week). Problem was not here before the update.  

Ever since the update last week, I’ve noticed that the load times have increased when I’m viewing my Media Library.  If I change the settings to view my network share, My folders load just fine and I can view my Media\backdrops just fine with ease.  Unfortunately, I like the perks of enabling the media library content because of trailers and info options.  When I enable, navigating across my 250+ movies **bleep** entirely because it does this weird loading thing.  If I sit on a movie, this is exactly what it does:  Loads backdrop.  Spinning Circle for thinking, loses backdrop, loads backdrop, spinning circle for thinking, loses backdrop… over and over and over.  If I navigate to the next movie skipping the backdrop loads in general, its OK, but once I stop and that backdrop gets a chance to load… I’ll have a delay.  I know this is not normal for performance… and I’m not sure what to do to resolve. 

Any ideas?  I’ve tried deleting all the folders\backdrops\etc and having the WD re-create it, but the problem still persists. Any help andsuggestions would be appreciated.

Nevermind.  I fixed it.  I did a factory reset.  Problem is no more and Streamer is actually somewhat faster while navigating through my movies.

case closed :)