Latest firmware 1.04.04 broke FTP & WebDav


Please explain what has changed in the WebDav and FTP authentication method with the new 1.04.04 update. Since I’ve installed it, hoping to sort out other issues, it’s been impossible to connect FTP either locally or over the Internet, same applies to WebDav.

WebDav actually never worked but FTP was a good workaround for my users, however nobody is now able to connect through FTP, we all get authentication error.

Please fix this ASAP or provide a solution.

Will create a bug report for this one

Could you please explain me if you did a system restore after the update?

Back up data first just for caution… but it should not loose any data with system restore

No system restore was done, I can access all the files locally with UNC (drive mapping) or over the VPN with UNC.

If I remove the device from my AD and login with the ADMIN user/password the FTP works (webdav never worked) but if I join the EX4 to my AD, then I get access denied on all users including ADMIN.

I’m willing to try a system restore, the EX4 is still under a month old and I have backup of all the files we’ve put there.

a system restore is recomended  :)

it may solve your issue

when you update firmware please do allways a system restore ( doesnt affect the data on hard drives)

Will that reset my device’s IP Adress to DHCP or will it keep its static addy?

im sorry a system restore looses all settings 

you are reverted to factory settings…  will clean up many errors in the future

sorry for the trouble

I’m giving it a shot hoping the device won’t reboot to a weird IP configuration I won’t be able to access. I imagine this will also break any iSCSI setups I have?

i think by default you dont have iSCSI  enabled… im sorry i dont even understand how that works :stuck_out_tongue:

i dont use iSCSI 

iSCSI is great. Using an iSCSI initiator (built into Win7 and up) it “maps” an iSCSI drive as if it were local, the speed is spectacular.

Sadly it doesn’t like multi-accesses so you’re limited to one PC connected to it, more will work but it will not work properly. 

My System Restore is in progress…

will need to read something

i even try to configure a long time ago but i couldnt understand what to do looool

didnt read the instructions so its my fault

Well, that system restore not only deleted all the data and shares (!!!) but also did not fix the issue. I still have no FTP/remote cloud/Webdav access and now the kicker is that even internal UNC doesn’t work.

I can’t even map with \servername\share anymore.

This unit is getting closer and closer to being returned.

In sorry, you have all your data backed up ?

If not talk to wd support and dont do anything more

They will help you like thwy have helped me

Yeah, all that stuff was backed up already, this unit was supposed to replace an old SAN drive but I’m thinking no way I’m going to put in production anything with valuable files and data that can wipe them this easily.

Good thing I was just testing.

:confused: yep i understand

I just sent an email to my wholesale company sales rep for a return procedure. Too bad. It looked cool. If WD put as much effort in their firmware integration, instructions and support, than in their cool LCD screens we wouldn’t be having this discussion.

good luck

they need to get their act together

we shouldnt lose any data doing a system restore !!  its not the first time we loose data after this

they are brilliant in hard drives, lets see iwhat they can do for this device

DavidSucesso wrote:

i think by default you dont have iSCSI  enabled… im sorry i dont even understand how that works :stuck_out_tongue:


i dont use iSCSI 

DavidSucesso - If you are interested here’s a simple tutorial on how iSCSI works. I know it’s for AsusSTOR NAS but the sub-stepsin 2.1 that are specific in step 2.1 (creating iSCSI and LUN) are very simple if you use the EX2/EX4’s dashboard settings to setup iSCSI. In fact, I didn’t know ANYTHING about iSCSI until I read this document a few months ago and then just tried it on my EX2 and it worked perfectly.

Thanks i will take a look :slight_smile:

I once did a system restore and thought I lost everything but as it turns out all I had to do was re-join AD and they came back. The next time a tech told me to create the shares prior to connecting to AD and once the shares were re-created the files showed up and were still there.

Could be a nightmare if you have lots of shares. but worked for me.

I just managed to connect via FTP by changing these settings. This is on EX2 thou.

Problem I was having was that my FTP was getting stuck in MLSD.

Hope this helps.