Last content source has been removed

I have a new WD TV Live Hub. I spent the last few days copying photos, music, and home movies to it. I am ONLY using the local drive … not connecting to any remote shares or DLNA servers. When I enable Media Library, it indexes for a few hours, then completes (the icon stops flashing, and the GUI does not say indexing anymore). But then when I browse my photos, only 70% of them show up (30% of the folders are missing) … and the navigation takes 15-30 seconds between folders, and eventually I get the message “The Last Content Sourlast content source has been removedce Has Been Removed …”.

When I disable Media Library, and reboot, browsing the local folders works fast, and sees all photos. I have disabled DLNA, network shares … but anytime I enable Media Library this happens. Any ideas?

I am on latest firmware, have about 120 gig photos, 100 gig MP3, 30 gig home movies (AVI, MP4, TS, etc). I have rebooted (soft and hard), powered down, etc … same results each time.


You can try clearing the media library

Thanks, I did try that, but the same results. I also tried turning off media library, rebootintg, turning Media Library back on, etc. No luck.

Since it uses a 1 TB drive, I assume it can handle large photo/music libraries, right? I have 600 gig or so of photos, music, and small video clips on its local drive. This device (and the media library) is designed to handle that, right?



Yes indeed… It can handle the entire collection

the larger the collection the more it takes compiling as you might expect

The compiling of the collections seems to take a few hours (based on blinking icon and status in GUI). I let it sit for two days … but still same problem.

It must be a faulty unit … I RMA’ed it and will try again.


I don’t think it should be taking you a few hours to compile. I have close to 2 TB of data-movies, music, (no photos though but that shouldn’t matter) on external and the internal drives and it takes about 10-15 minutes to compile.

Have to agree with Cosber, I have the internal drive on the HUB about half full, but also have the media library checking multiple 2 & 3TB drivves on 3 different computers and it only takes about 10-15 minutes to scan. I don’'t think it should take hours for you.

Good Luck


I received my new replacement unit a few days ago from Amazon … I then loaded most recent firmware … loaded up pictures and music … re-enabled Media Library … but this unit now says rebuilding library for the last 54 hours. So, either the WD HD Hub is not compatible with some of my photos/music, does not like how many items I have (90,000 photos, 22,000 MP3, 300 AVI), or there is a bug in the most recent firmware :frowning:

I will try rolling back a release to see if that changes anything. I see others are having the same issue … has anyone resolved what this is?

Well I tried three different older firmwares … same results for each :frowning: I think I can conclude that the WD TV Hub does not support that many photos or MP3s. Which is sad really … it is like selling a van that has 8 seats, but the car only drives if there are 4 passengers (only half of the 1 TB drive is used).

Are there any other devices that offer similar functionality (e.g. built-in drive, DLNA server)?

Jay, have you tried adding them in smaller batches?

Kind of … each time I disabled the media server (so it was not updating during the copy), then copied about 50 gig at a time. It takes forever doing it this way, but I find Windows 7 bulk copy is not too reliable for larger copies. Then after copiing all the data (takes about a day), I enabled media server.

I think the base problem is that the WD Live Hub only supports relatively small libraries (compared to the size of the built-in drive) of photos and MP3s. I found others posting in other forums with the exact same problem, and there has never been a resolution.

I noticed that all similar devices (and this one) use an old version of Twonky. I am going to return this, and try the Iomega one but I fear the same results.

When I “start from scratch” It CAN take a long time to compile all the files. Especially if I’m trying to do so many TB at once. What I usually do is, to counteract this lengthy process, is that when a “functunal” firmware upgrade is out and has the concencous of the majoriy as “okay”, I’ll eject/unplug all 14TB external USB HDDs (I think this is an action recomended in the faqs when upgrading firmware). Either way, it’s prudent to keep files safe during a any FW update. Along that line of thought, I only upgrade using a usb key dongle. I disconnect totally from the network. FW goes smoothe.

Now, this may seem like a time waster, and for all I know, maybe the newer FW can handle everything plugged in while it updates, but again, I;d rather be stingy with my files. Better safe than sorry.

When its complete, I’ll turn off my media library. Then plug in all 14TB external usb HDDs at the same time. Then I clear the media library completely. This way it doesn’t start to compile the HDDs. Then I’ll eject each HDD again and plug into my computer, so I can delete each “.wdtv” folder (thumbs etc) found on the 5 external HDDs (While keeping all my .jpgs .avi .mkv’s etc and .xml movie sheets etc)

That’s a lot to describe for only 5-8 minutes of action. Anyway, with the hub still unplugged from any network, I’ll turn on the media library and walk away for 5-15 minutes to let it compile the internal 1TB HDD (I have about 610GB used on the internal drive, all photos and mp3s). Once I return and see the WD light has stopped flashing at me, I go into setup and Restart the device.(I find that if I restart the device while plugged to a network, the restart process hangs in recent FWs.) Anyways, a minute later its up and running again. Now is when I attatch the USB 4 port hub and then attatch ONE external HDD enclosure while still powed off. The I turn the ext dual HDD enclsue on, and walk away for 40 minutes while it compiles the 6 TB of video files. Sometimes its done when I come back, sometimes I have to wait an extra 5 more minutes. Once that’s done, I go to setup again and restart, then repeat with each of the other external HDDs.

All in all, the upgrading of the FW and the compiling of atleast 14 point something TBs takes me at least 3 and a half hours. Of which I’m only present interacting with the WDHUB for all of, say 20 minutes, cause I’ve got other cleaning to do around the house. (Compared to if I had plugged all the ext HDDs at once and let it compile, aprox one to one and a half days to compile, which I only do if I’m going to bed or going out for the night at the pub)

Once that’s all done, I’ll finally connect the WDHUB to the network, which is basically, for me atleast so I can get to see what the weather is like. I like it’s Web Browser, but not enough to use it, since it doesn’t allow upgrading Flash, Bookmarking or anything else really. Not to mention the twonky is out of date as well. I don;t use the “services or the games” Because my PS3 has a Youtube app, as well as Crackle, Hulu, SportsTV, Netflix and CrunchyRoll apps. And it was built for gaming. So all that fluff on the HUB, to me at least is redundant and moot. Others may feel differently, and are welcome to their own opinion,

But, with Adobe Flash being phased out of certain technolgies, I’d have at least thought that Sony, as well as WD, would at the very least update/upgrade to the leatest available version out there for their respective runtime environments. The WD is Linux, I think. At least that’s what adobe site offered me when I tried to update the WD Hub’s web browser’s flash to the latest it could run. But it was denied access so, THAT didn’t happen.

However, all that aside, I may prefer to have the Media Library set to ON so I can have my sorts and extra info. It is true, that the more files compiled the slower it takes to “display”. For me its about a 5-8 second delay between screens or folder loads. (But that’s when I had every movie in its own folder, which I no longer do. Movies are in the same folder as the rest along with their xmls and thumbs etc. Now my next screen/folder load/read is 3-5 seconds delay.

When Library is OFF, half a second read/load, easy-peasy pudding & pie.

It IS a great little device. It plays everything I throw at it, and what it didn’t in the past, now does, especially .ogm files from back in the day of the mkv or ogm battles (reminded me of the Bluray or HDDVD war lol). Its just that every FW update is iffy at best, but they (the devs) ARE gettig better at pinpointing their previous bad code that end up being re-introduced. Now if they’d focus more on theme/skinng and codec and interface tweaks, rather than their “Services” and “games” sections, I’d be a happy camper. But don’t get me wrong, just because I Don’t use those features, doesn’t mean others can’t live without them. So as long as they try to balance out their updates/upgrades, in the long run I’m content.

Being paitent helps though.

A Side note, anytime I restart the device, while network is pluggged in, it freezes for a long time while loading, and when it finally does load (usually when I press left or right on the remote keys because I got impaitent, the main screen loads up, but the internal HDD is not present, which results in the “last content source has been removed” message. Happens for the last 2-3 updates. Which is why, unplugging the network (ethernet cable) has become a necessity when restarting the device, not just a fancy of mine to not confuse the little black box when upgrading FW.