"Last content source has been removed" again and again

Hello all,

I have recently purchased a WDTV Live Streaming and I have some problems with network shares: every time I restart the device (whether it is a system restart or that I turn it off for some time) it looses the network share and I am greeted with the “last content source has been removed” message. In addition, when I reconfigure the source I randomly have an error “unable to connect …” and I need to restart the device, again.

My media server is a netbook on XP Home with USB external drives. This is no military grade server I agree, but I can access it from any other computers in my home, including MacBook Pro and 2 Sonos devices, without any problem. Both the server and the WDTV have static IP and are on the same domain. It is a wired network.

In addition I did some test with Ubuntu for NFS sharing and I have still the same problem.

I am the happy owner of a WDTV Live (previous gen) with B-RAD firmware and I purchased the new one because I wanted to increase the WAF of my setup and I am more comfortable with official firmware, but right now it’s a failure.

Thank you,


If you RESTART the device, you need to give it a few minutes AFTER the menu appears before you browse to anything.

It takes a few minutes for the network to be activated, IP address assigned (if DHCP), Servers to be discovered and connected, and the media library (if you’re using it) to be quick-scanned.

On mine, I know it’s ready to go when the “New Files” indicator on the Videos tab changes to the correct number.

Wow, that was fast !

Thank you for the answer, but is there a way to speed up this process ? If my connection’s information is stored in the WDTV, shouldn’t it be able to connect to the server “instantly” ?

Is there some kind of standby power mode for the device (or do you always leaves it on) ?

  • “On mine, I know it’s ready to go when the “New Files” indicator on the Videos tab changes to the correct number.”

OK, I have always seen this “New Files” indicator at 0. Should I use the media library to activate it ?



Well, if you press the power button “quickly,” it goes into Standby and the network remains active.

If you press the power button more than 3 seconds, it does a full shutdown.

I’ve not had the problem you describe when bringing it out of Standby.   

  • "Well, if you press the power button “quickly,” it goes into Standby and the network remains active.

If you press the power button more than 3 seconds, it does a full shutdown."

Interesting. I am using an Harmony remote so maybe that’s the cause of the problem.

Ok, so I have done some tests yesterday and the problem came form my Harmony remote (600 model).

The WD TV Live Streaming (2011) doesn’t exist yet in the Harmony database. You have to choose between the WD TV Live (previous gen) or the WD VT Live Hub. Initially I choose the WD TV Live Hub because the remote is similar.

However, each time I sent a “power off” signal with the Harmony remote, the device was put in “Off” mode instead of “standby” mode. Therefore, each time I restarted the WD TV, it took minutes to boot up, find the network and the network shares.

Problem was solved by using the WD TV Live setup in the Harmony database and adding the others buttons with the “Learn IR” function.

I guess Logitech is monkeying around with the device database then, because the HUB and the Live SMP use identical remote.

I have the Harmony One, and I used the WDTV Live profile because the Hub didn’t exist yet.   I did exactly what you describe.

I have seen this happening with my setup - not using a logitech; but another universal remote - and I doubt the restart or standby mode is the root issue here.

When the unit is on standby or powered off - I cannot remember which is which  but I know I’ve had issues regardless of the power mode it is in.  when I try to do a manual scan it tells me that the media library is readonly. Which does not make any sense, because if it was I wouldn’ t have been able to create a media library in the 1st place.

When I remove the path and add the path back in, it adds the path successfully. But when I run a manual scan again it tells me the folder is read only.

Another issue I had is the message that OP mentioned - ‘last content source has been removed…’ . In this case I let it sit there and scan again. Sometimes it’s unsuccessful and I have had to manually remove the folders and add them back in again. This sometimes resolves the issue but sometimes it doesn’t. Situations where it does not, I have found that when I went back to the video folder it tells me that there is no media in the folder - which is a tad silly since I’ve not changed the folder at all.

I sincerely believe that there is something buggy with how the unit is linking up etc. I am on a wired network btw. I will try to give a better detail on the ‘issue’ when I get back.

Hi monsieur_paul,

I had the same issue using the Live HUB profile on my Harmony One remote.  However, to fix it in the Logitech software I simply did the following by starting with the Live HUB profile:

  1. Go to the “Devices” tab.
  2. Choose “Settings” for the Media PC (WDTV Live Streaming) device.
  3. From here choose “Adjust power settings” and click “Next”.
  4. Choose “I want to turn off this device when it’s not in use” (but you can choose your own preference) and click “Next”.
  5. Choose “One button on the remote for turning it both On and Off” and click “Next”.
  6. Choose either  a)  “I have the original remote and know what button to press” and do the learning process for just pressing the button (not holding it) or  b)  change the delay so it’s something like 500ms instead of 3000ms.  This is what’s causing it to do the hard-shutdown instead of going into standby.
  7. Finish going through the wizard and update your remote.

That should be a bit easier and save others from having to “learn” a bunch of extra buttons.


Thanks for the info ! Your solution is better indeed.